Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

When I use the command

$ sudo lpoptions -d Deskjet-F300-series

it won't change the default printer.

$ lpstat -a
Deskjet-F300-series accepting requests since Sun 10 Apr 2011 11:02:12 AM CEST
Deskjet-F4200-series accepting requests since Mon 04 Apr 2011 03:39:17 PM CEST
Deskjet_F4200 accepting requests since Mon 04 Apr 2011 03:39:17 PM CEST
HP_Deskjet_F4200_series accepting requests since Mon 04 Apr 2011 03:39:17 PM CEST

$ lpstat -d
system default destination: HP_Deskjet_F4200_series

$ lpstat -p
printer Deskjet-F300-series is idle.  enabled since Sun 10 Apr 2011 11:02:12 AM CEST
    Printer is now online.
printer Deskjet-F4200-series disabled since Mon 04 Apr 2011 03:39:17 PM CEST -
    Unplugged or turned off
printer Deskjet_F4200 disabled since Mon 04 Apr 2011 03:39:17 PM CEST -
    Unplugged or turned off
printer HP_Deskjet_F4200_series disabled since Mon 04 Apr 2011 03:39:17 PM CEST -
    Unplugged or turned off

Do you know where is the fault?

Thank you

share|improve this question

1 Answer 1

up vote 2 down vote accepted

sudo lpoptions -d sets the system-wide default printer (by editing /etc/cups/lpoptions). You may also have a per-user default printer, which overrides the system-level setting. The per-user default is stored in ~/.cups/lpoptions; you can change it with lpoptions -d.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.