Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a Huawei cell modem EM680 with which I can establish a connection on my Ubuntu 13.10 box just fine. I plug it in and I can establish a connection using the Connections Manager.

I have a box without X server and I want to establish a connection with that same modem on that box. I can get a serial link at /dev/ttyUSB1 and if I connect to it using screen /dev/ttyUSB1 460800 and send AT, it responds with OK just fine — so the modem works! Ater that I tried to establish a connection using wvdial with my /etc/wvdial.conf configured like this:

[Dialer Defaults]
Init1 = ATZ
Init2 = AT+CFUN=1
Init3 = AT+CGDCONT=1,"IP","m2mstatic.apn"
Modem = /dev/ttyUSB1
Phone = *99***1#
Modem Type = USB Modem 
Username = "blank"
Password = "blank"
Stupid Mode = yes
New PPPD = yes
Baud = 460800
ISDN = 0

I tried to launch wvdial without any options or with wvdial eap-interval 1 require-chap because in my Connection Manager window, under the tab PPP following checkboxes are checked: EAP, MSCHAP, PAP, MSCHAPv2, CHAP, Use BSD data compression, Use Deflate data compression and Use TCP header compression. But upon launch I just get

# wvdial eap-interval 1 require-chap
--> WvDial: Internet dialer version 1.61
--> Warning: section [Dialer eap-interval] does not exist in wvdial.conf.
--> Warning: section [Dialer 1] does not exist in wvdial.conf.
--> Warning: section [Dialer require-chap] does not exist in wvdial.conf.
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: AT+CFUN=1
AT+CFUN=1
OK

--> Sending: AT+CGDCONT=1,"IP","m2mstatic.apn"
AT+CGDCONT=1,"IP","m2mstatic.apn"
OK
--> Modem initialized.
--> Sending: ATDT*99***1#
--> Waiting for carrier.
ATDT*99***1#
CONNECT 14000000
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Mon Jan 22 03:26:56 2007
--> Pid of pppd: 4295

Here it waits for a about a minute and then:

--> pppd: H�[02]
--> pppd: H�[02]
--> Disconnecting at Mon Jan 22 03:27:57 2007
--> The PPP daemon has died: Connect script failed (exit code = 8)
--> man pppd explains pppd error codes in more detail.
--> Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.
--> Auto Reconnect will be attempted in 5 seconds
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
--> Sending: ATQ0
--> Re-Sending: ATZ
--> Modem not responding.
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
--> Sending: ATQ0
--> Re-Sending: ATZ
--> Modem not responding.
--> Disconnecting at Mon Jan 22 03:28:19 2007
#

but I can never actually reach the internet. Exit code 8 in the pppd man page says: The serial port could not be opened. — which is ridiculous as I just opened (and closed(!) it with screen). Any ideas where I'm going wrong or what I'm missing?

edit

I just found the connection manager's config file and it looks like this, that might help too, hey?:

[connection]
id=Rogers
uuid=5c4ed6f8-9ece-4888-a129-65ed5c741502
type=gsm
permissions=user:ron:;

[gsm]
number=*99#
password-flags=1
apn=m2mstatic.apn
pin-flags=1

[ipv4]
method=auto
share|improve this question
    
Are you sure about that exit code? On my system, code 8 is The connect script failed (returned a non-zero exit status). –  terdon Jan 18 at 15:10
    
@terdon I got this from ppp.samba.org/pppd.html –  cerr Jan 18 at 21:35
    
Check your system's manual page (man pppd), you probably have the same as I do (on Debian) and that is a different error code. –  terdon Jan 19 at 15:31
    
@terdon ok, on my actual box, error 8 is The connect script failed (returned a non-zero exit status). –  cerr Jan 21 at 3:54
1  
First of all fix your system clock. Some providers refuse connection if date is wrong. Is your apn correct ? –  totti Jan 22 at 17:08

1 Answer 1

first you need to see if your hardware is listed:

lsusb

then you can install and configure usb_modeswitch because linux recognize your hardware as a usb drive not as a modem (i assume that you are using archlinux):

pacman -S usb_modeswitch

finally you just got to check if your APN settings are correct:

wvdialconf

vim /etc/wvdial.conf

a simple script to make it automatic:

usb_modeswitch

sleep 2

modprobe usbserial vendor=0xVVVV product=0xMMMM maxSize=4096

sleep 2

wvdial 'your profile'

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.