Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I've installed a server (WSO2 ESB) in my laptop.

When I run it, going to the browser and typing the console address https://10.13.6.75:9443/carbon, it works normally, but if I try it on another machine on the network, it gives timeout.

Some observations:

  • ping works
  • telnet respond on ssh port (22) but not in 23, 8080, 9443, etc
  • I've already executed service firewalld stop, service iptables stop, and disabled the selinux, but no results.

There's another process involved blocking the requests?

share|improve this question
1  
It 's paerfectly normal that ssh can't connect on 23 8080 or anything but 22 with default config –  Kiwy Jan 16 at 14:28
    
@Kiwy OP wants to check if port is open, not to initiate SSH connection. –  Chris Jan 16 at 14:45
    
Can you tell us what web admin interface are you using there is chance you need to extends the listenning address of it. –  Kiwy Jan 16 at 14:51
    
@Kiwy Is a common web interface. There's another addresses like wsdl url, rest services url, but none of these works outside my laptop, just on localhost. –  Elias Jan 16 at 15:18
1  
@Kiwy - he's on Fedora, that's a Debian/Ubuntu file. Please only attempt to assist if you know specifics. Otherwise you're just confusing the OP and the Q&A. –  slm Jan 16 at 16:29

1 Answer 1

up vote 3 down vote accepted

Fedora 19 uses the firewall firewalld.service. You can see if it's running from a terminal using this command:

$ systemctl status firewalld.service 
firewalld.service - firewalld - dynamic firewall daemon
   Loaded: loaded (/usr/lib/systemd/system/firewalld.service; enabled)
   Active: active (running) since Sat 2014-01-11 17:02:00 EST; 4 days ago
 Main PID: 564 (firewalld)
   CGroup: name=systemd:/system/firewalld.service
           └─564 /usr/bin/python /usr/sbin/firewalld --nofork --nopid

Jan 11 17:02:00 greeneggs.bubba.net systemd[1]: Started firewalld - dynamic firewall d...n.

You can disable it, temporarily like this:

$ sudo systemctl stop firewalld.service

Now it's off.

$ systemctl status firewalld.service 
firewalld.service - firewalld - dynamic firewall daemon
   Loaded: loaded (/usr/lib/systemd/system/firewalld.service; enabled)
   Active: inactive (dead) since Thu 2014-01-16 10:20:42 EST; 11s ago
 Main PID: 564 (code=exited, status=0/SUCCESS)
   CGroup: name=systemd:/system/firewalld.service

Jan 11 17:02:00 greeneggs.bubba.net systemd[1]: Started firewalld - dynamic firewall d...n.
Jan 16 10:20:39 greeneggs.bubba.net systemd[1]: Stopping firewalld - dynamic firewall .....
Jan 16 10:20:42 greeneggs.bubba.net systemd[1]: Stopped firewalld - dynamic firewall d...n.

To restart it:

$ sudo systemctl start firewalld.service 

If you're new to Fedora, or just new to 19, I highly suggest reading the Fedora Project's documentation on firewalld.

What ports are open?

You can use the command line tool nmap to see what ports are accepting connections on your system.

$ sudo nmap -sS -P0  192.168.1.161/32

Starting Nmap 6.40 ( http://nmap.org ) at 2014-01-16 11:06 EST
Nmap scan report for 192.168.1.161
Host is up (0.000019s latency).
Not shown: 998 closed ports
PORT    STATE SERVICE
22/tcp  open  ssh
111/tcp open  rpcbind

Nmap done: 1 IP address (1 host up) scanned in 0.11 seconds

Be sure to substitute your system's IP address in the above command.

netstat

Alternatively you can use the command netstat to see what ports are in use and which PIDs and IP's they're bound on.

$ sudo netstat -anpt | grep :22
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      894/sshd            
tcp        0      0 192.168.1.161:52732     67.253.170.83:22        ESTABLISHED 5023/ssh            
tcp6       0      0 :::22                   :::*                    LISTEN      894/sshd            

NOTE: This lists the IP addresses that have sshd bound to port 22.

Binding to ports on specific interfaces

Many people get confused by this but each interface in IPv4 has it's own set of ports. You need ot make sure that when you start a service that you take care to tell the app that you want it to bind to IP address's 127.0.0.1's port XYZ vs. the IP address for you NIC card's port XYZ.

You application appears to provide this type of feature. It's discussed in this documentation.

There's an XML file according to the docs where you can change your IP to bind to.

<parameter name="bind-address" locked="false">hostname or IP address</parameter>
share|improve this answer
    
The status is Active: inactive (dead) –  Elias Jan 16 at 15:34
1  
use nmap to see if ports are open, not ssh –  Thorsten Staerk Jan 16 at 15:38
    
@ThorstenStaerk - thanks added suggestion showing how. –  slm Jan 16 at 16:07
    
@Elias - if it's in the state of dead, you shoule try restarting it. sudo systemctl restart firewalld.service. –  slm Jan 16 at 16:07
    
Really, using nmap, the ports opened is 22, 111, 9999, 10000 and 11111. –  Elias Jan 16 at 16:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.