Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I need some help from you guys regarding NTP on Suse.

I have a server, whose IP is, which is based on Suse Linux and here is my NTP conf file:

server  iburst
logfile /var/log/ntp is another NTP server in the network.

Now, when other linux systems have their ntp server as, the NTP service starts, but time does not sync. In the NTP clients, on ntpdate <IP> or sntp <IP>, the error I get is: "sntp: too many bad or lost packets".

On the NTP server (, I get this error in the log file (/var/log/ntp):

15 Jan 16:38:21 ntpd[15262]: ntpd exiting on signal 15

Also when I do ntpdate <IP> or sntp <IP> on the NTP Server, I get: "sntp: too many bad or lost packets".

The server is plain installation of OpenSuse along with MySQL installed. SuseFirewall is disabled and there is no other antivirus or firewall in place. All ports are open, still not able to sync from server (also the NTP server is not able to sync with any other machine).

How can I get it working?

share|improve this question
what's does ntpdate -d say? Have you tested w/o the restriction first? – djf Jan 15 '14 at 12:11
@djf This is the output of sntp: too many bad or lost packets when i try sntp I get the same above error – user56807 Jan 15 '14 at 12:29
Remove the line restrict Also, remove the "iburst" suffix from the "server" line then stop/start ntpd. See if that helps. – Bruce Ediger Jan 15 '14 at 14:05
@BruceEdiger that didnt help too ... still getting "ntpd exiting on signal 15" in logs and sntp: too many bad or lost packets on ntpdate – user56807 Jan 16 '14 at 4:18
That is the entire ntp.conf? What was wrong with the default config file from Suse? I am not sure why someone said remove iburst, iburst is good. But that restrict line was awful – dfc Jan 17 '14 at 23:18

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.