Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am trying to transfer files over to my virtual machine

I tried the command

scp files user@xxx.xx.xx.xxx:/home/user/directory

I am later asked to enter the password for user@xxx.xx.xx.xxx

When I enter the password the output is:

scp: /home/user/directory/filename: Permission denied

I thought perhaps I don't have the correct permissions or rights to the files?

So I checked rights for each file and it is


Not really sure what I need to do to correctly SCP my files over to my virtual machine

share|improve this question

closed as unclear what you're asking by slm, Anthon, terdon, Zelda, jasonwryan Jan 14 '14 at 19:22

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

you definetly should check if user that you truing to ssh with, has permissions for /home/user/directory/filename also check if files that you scp has permisions to be executed with the current user that you trying to scp with –  klerk Jan 14 '14 at 17:54
If you are putting the file into that user's actual home, try scp files user@host:directory/. Also, ssh user@host ls -ld directory to make sure that directory exists and is set u+w. –  DopeGhoti Jan 14 '14 at 18:04
Please give us some more info. Post the output of ls -l /home/user/directory/ from the virtual machine. Also tell us what OS you are running as home and guest, you never know. –  terdon Jan 14 '14 at 18:28
scp won't work unless ssh works, and you may have to enable sftp as well... –  Wilf Jan 14 '14 at 18:49

Browse other questions tagged or ask your own question.