Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I use a modified vim in Arch Linux, so I blocked gvim and vim-runtime from upgrading:

In /etc/pacman.conf I have:

IgnorePkg = gvim , vim-runtime, vim, ...

But when I do pacman -Syu, it still checks if gvim could be upgraded:

looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: gvim: requires vim-runtime=7.4.86-1

Any ideas?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

IgnorePkg is supposed to be space separated, not comma separated. I suspect this may be what is causing the issue:

IgnorePkg=gvim vim-runtime vim
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.