Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a BMC42142 wireless adaptor

lspci -vnn | grep 14e4:
02:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01)

and I can't connect to the wireless lan. I'm using wl drivers

sudo lspci -vnn -d 14e4:
02:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01)
    Subsystem: Lenovo Device [17aa:0611]
    Flags: bus master, fast devsel, latency 0, IRQ 17
    Memory at d0400000 (64-bit, non-prefetchable) [size=32K]
    Capabilities: [40] Power Management version 3
    Capabilities: [58] Vendor Specific Information: Len=78 <?>
    Capabilities: [48] MSI: Enable- Count=1/1 Maskable- 64bit+
    Capabilities: [d0] Express Endpoint, MSI 00
    Capabilities: [100] Advanced Error Reporting
    Capabilities: [13c] Virtual Channel
    Capabilities: [160] Device Serial Number 00-00-a2-ff-ff-f5-00-90
    Capabilities: [16c] Power Budgeting <?>
    Kernel driver in use: wl

My wireless modem is TP-Link TD864W and I share this information 'cause I cannot say for sure whether the problem is caused by my adapter or by the modem. Here are the symptoms:

  1. I cannot connect to my wireless modem from my laptop. It stays in the "connecting" status.
  2. But my android tablet can connect to it.
  3. I can connect to my neighbor's modem and even a wireless printer two floors down.

What I've tried:

  1. I tried to connect by disabling DHCP and choosing a static IP. This time it says "connected" but I could not browse any sites.
share|improve this question
1  
If you can connect when not using DHCP, your device is fine. You can't browse the internet because your network settings are wrong. Could you show us a screenshot of your connection settings (IP settings tab)? We need to know the IP of your modem/router and the settings for Gateway, Netmask and DNS servers. –  terdon Jan 7 at 12:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.