Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have configured /etc/network/interface like this:

auto lo eth0
iface lo inet loopback
iface eth0 inet dhcp

But when a lease cannot be obtained, the booting is not completed. Is it possible to leave DHCP enabled but, in case a DHCP lease is not achieved, still complete the boot (so that a new network configuration can be performed)?

share|improve this question
1  
This is not a reason for not completing the boot process. Maybe it gets long pauses when services (like mail) are waiting for dns resolver to timeout. In this case if you wait enough time the system will boot. Disable the boot splash screen or switch to console with ALT-F1 to see the booting messages. –  forcefsck Apr 7 '11 at 12:15
    
What distribution is that, and what networking-related settings did you tune? –  Gilles Apr 7 '11 at 21:35
    
@Gilles Looks like Debian-based, probably Ubuntu. Still, should not be a reason for it to not boot, maybe just take longer. –  penguin359 Apr 7 '11 at 23:19
    
Not Ubuntu, nor Debian. It is a customized busybox. –  michelemarcon Apr 8 '11 at 9:39
add comment

1 Answer 1

up vote 3 down vote accepted

There is a undocumented parameter to udhcp which sends it to the background and allows to boot.

udhcpc -b
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.