Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

What can I do to run TaxACT 2013 under Wine 1.4.1 on Debian Wheezy amd64?

Running TaxACTenter link description here from a terminal gives this:

$ env WINEPREFIX="/home/bill/.wine" wine "C:\TaxACT\TAXA~SPJ\TaxACT13.exe" 
fixme:ieframe:PersistStreamInit_InitNew (0x14f2a8)
fixme:ieframe:WebBrowser_put_RegisterAsDropTarget (0x14f2a8)->(0)
...

Wine also produces a backtrace that starts

Unhandled exception: page fault on read access to 0x00000000 in 32-bit code (0x0075a7d0).

I can provide more details, if it's helpful.

I did install the i386 version of gnome-keyring-pkcs11.so manually to get this far.

FWIW, the 2012 version fails, too, but the 2011 version seems to work.

Does the fixme:ieframe:... suggest something obvious?

share|improve this question
    
vaab's comment on askubuntu.com/questions/127848/… shows how I installed gnome-keyring-pkcs11.so . –  Bill Jan 5 at 1:41
1  
Searching the wine appdb, it does not appear as if TaxACT is running in wine at all, not 2011 or 2012. No test results for 2013. I think your best option is to run windows in a VM or dual boot. –  bodhi.zazen Jan 5 at 2:12
    
I filed a report a few days ago for 2013, but it got deleted. I see 2012 as bronze (I rated it); it worked for me. In fact, I've used TaxACT on wine for perhaps 8 years or so. Each year seems to have a few issues, but the serious ones get resolved easily. I just don't yet know what to do about this year's version. –  Bill Jan 5 at 3:02
    
Those errors suggest the application is using IE functions that have not been fully implemented in Wine yet- have you tried installing IE7 in your Wine environment using Winetricks? wiki.winehq.org/winetricks –  James Hebden Jan 5 at 4:11
    
Thanks. I'm running winetricks 20130707. I run winetricks as me, select "Install an app" from the menu, and don't see any option to install ie*. Am I doing something wrong? –  Bill Jan 5 at 16:25
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.