Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am having some trouble disabling the italics in emacs.

I already tried:

 '(italic ((t nil)))

in .emacs. But there is still a problem.

Although it will not italicize the text between / and /, these /s will disappear. So, when I want to write:

/home/Quora/

it actually shows:

home/Quora

How can I avoid emacs from trying to change a face, and using the mark-up, when I type /something/?

I am using org mode in emacs 24 in Ubuntu.

share|improve this question
    
Please don't cross-post. If you want this question to be here, please delete your question on Super User. –  terdon Jan 2 at 13:07
    
Is it only in org-mode that you don't want to see italics, or is it in other places too? –  Jenny D Jan 2 at 13:08
    
@terdon: del done! –  Quora Feans Jan 2 at 13:08
    
@JennyD: I only use org mode, shell, dired. In the last two this is not a problem. So, org mode is enough, but I don't mind generally disabling it too. –  Quora Feans Jan 2 at 13:10

3 Answers 3

up vote 1 down vote accepted

Found solution:

I had to disable the markers //s.

Went to M-customize-variable RET org-emphasis-alist RET and deleted the / item from the list.

share|improve this answer
    
Ah, I misunderstood part of your question. Thanks for posting this answer! –  Jenny D Jan 2 at 14:12

To disable italic and bold from the customize mode:

M-x customize-face RET italic RET

Unmark the box marked Slant:

Then, click Save for future sessions

M-x customize-face RET bold RET

Unmark the box marked Weight:

To do the same thing in your .emacs:

(custom-set-faces
'(bold ((t nil)))
'(italic ((((supports: slant italic)) nil))
)

If there is already a custom-set-faces section, just add the middle 2 lines to it.

share|improve this answer
    
That disables italic, but it was already disable. The problem is that with (setq org-hide-emphasis-markers t), the italic markers (//) disappear. So, a dir name /home/ shows up as home. –  Quora Feans Jan 2 at 13:28
    
Don't do that then :-) Instead of using org-hide-emphasis-markers, disable italics from the start. Or disable font-lock-mode, that will have the same effect. –  Jenny D Jan 2 at 13:36
    
that would have other collateral effects :( I still want to hide the mark-up of *bold* to show it as bold. –  Quora Feans Jan 2 at 13:39

Add this to your .emacs file to hide markup.

(setq org-hide-emphasis-markers t)
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.