Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I usually use my Linux Mint 15 installation on my PC. I have separate / and /home partitions. /home is encrypted with ecryptfs, which I did not configure myself, I just ticked the "encrypt home" when installing Mint.

I have today installed Debian, with it's own /-partition. I also chose the same /home partition I use on Mint, because I want to share all files in /home between the two. I was hoping that Debian would automatically recognize /home as encrypted with ecryptfs and decrypt it for me with my user password. But it did not. When I log in on Debian I get this error message:

Could not update ICEauthority file /home/fridge/.ICEauthority.

My only option is to log out.

The /etc/fstab entry in Mint does not mention ecryptfs anywhere, /home is just mounted as ext4. That was my first thought, that it would mount in fstab.

How do I configure Debian to automatically decrypt /home for me when I log in?


EDIT: I belive I misunderstood the problem! Today I started up Debian and instead of logging in through the greeter I pressed Ctrl+Alt+F2 and logged in through the command line. The /home partition was decrypted! Apparently Debian does that for you like Mint. I tried startx but encountered the same problem as I was logging in through the GUI xauth: timeout in locking authority file /home/fridge/.Xauthority. Should I close this question now?

share|improve this question
    
howtoforge.com/… - part 4 maybe ? –  John WH Smith Jan 1 at 21:28
    
@JohnWHSmith The article you linked uses an entierly diffrent way to decrypt it though. There a key is put on a usb drive which is mounted in fstab. This is not how Mint set it up to work! –  fridge Jan 1 at 21:57
    
Debian doesn't set up ecryptfs automatically during system installation, it's more hands-on than Ubuntu or Mint. Have you installed the ecryptfs package? –  Gilles Jan 1 at 23:25
    
@Gilles I have chrooted into Debian and installed ecryptfs-utils and tried to poke around at things. Thing is I don't know where (in the configuration, not fs) the mount should be done. –  fridge Jan 1 at 23:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.