Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a new Intel NUC D54250WYK. I would like to install the latest Debian stable version. After successfully booting from a CD burned from debian-7.3.0-amd64-netinst.iso, the install fails with:

No Ethernet card was detected.  If you know the name of the
driver needed by your Ethernet card, you can select it from the list.

According to the specs, this machine has an Intel I218V Gigabit Ethernet controller.

I tried choosing the e1000e driver, but the same screen reappears.

When I go to the command line I can use lspci to see:

# lspci -v | grep Ethernet
00:19.0 Ethernet controller: Intel Corporation Device 1559 (rev 04)

Is this a matter of the installer not having the necessary updates for this hardware, or is this a problem with the hardware itself?

EDIT: I have subsequently also tried the debian-7.3.0-amd64-xfce-CD-1.iso. The same problem occurs. This is the more detailed lspci output:

# lspci -vnnk -s 00:19.0
00:19.0 Ethernet controller [0200]: Intel Corporation Device [8086:1559] (rev 04)
        Subsystem: Intel Corporation Device [8086:2054]
        Flags: bus master, fast devsel, latency 0, IRQ 5
        Memory at f7c00000 (32-bit, non-prefetchable) [size=128K]
        Memory at f7c3c000 (32-bit, non-prefetchable) [size=4K]
        I/O ports at f080 [size=32]
        Capabilities: [c8] Power Management version 2
        Capabilities: [d0] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [e0] PCI Advanced Features

David

share|improve this question
2  
Please use lspci -vnnk -s 00:19.0. –  Braiam Dec 30 '13 at 23:43
    
Thanks, I edited the question to include the requested output. –  David T. Pierson Dec 31 '13 at 4:59
    
Debian network installation CDs are quite less in size, and often doesn't have all the drivers -- I guess the ones that strictly do not comply with Debian policy. I usually download those specific drivers before hand, and put them in a USB drive, and use it during the installation. Otherwise, those packages could be installed later after the OS installation is done. –  Barun Dec 31 '13 at 4:59

3 Answers 3

Not being able to detect an Ethernet card is usually a driver problem. The installer sees a component on your computer, but is unable to realise "oh! that's an ethernet network card!".

I would suggest you to use a more complete installer (from what you say, you are using a netinstaller, which is very very very minimal). Try using a complete ISO instead. See :

share|improve this answer
    
Thanks for the response. Unfortunately I get the same result using debian-7.3.0-amd64-xfce-CD-1.iso. –  David T. Pierson Dec 31 '13 at 5:01
    
Maybe you should have a look here (debian.org/CD/live), and troubleshoot the bug from a Live Debian ? :) –  John WH Smith Dec 31 '13 at 15:19
up vote 0 down vote accepted

I found a thread on the Debian User Forums detailing a similar problem with a new Intel ethernet controller (though the controller itself is different than mine). The suggestions there are to try the testing installers or to use a kernel from backports.

EDIT: I tried one of the weekly builds of Debian testing and Ethernet is now working in the installer.

share|improve this answer
    
Do you know where I can download a precompiled driver? I need a driver for Debian wheezy, i386, Ethernet Pro 100 rev 8 82557/8/9/0/1 –  Giorgio May 23 at 18:32

I have had the same problem installing debian-7.6.0-amd64.iso next to Windows 8.1. Then I tried to install via "expert graphical mode" and it suddenly worked without further problems.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.