Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

After adding Service Pack 1 to my work computer, I get permissions errors when trying to RDP to work. I have no issues if I'm using the Microsoft Remote Desktop client.

I'm using Ubuntu 10.10 with Remmina Remote Desktop (I'll add the version when I get home, whatever is default in the base repository). Remmina (which is really nice, btw) uses FreeRDP.

I can't seem to find any other reports of this. Anybody have an suggestions?

Here is the screenshot (edit: not enough rep to post image, transcribed). And yes, I ignored the fact that it works on the MS client and checked that the permissions it asks for were fulfilled.

To log on to this remote computer, you must be granted the Allow log on through Terminal Services right. By default, members of the Remote Desktop Users group have this right. If you are not a member of the Remote Desktop Users group that has this right, or if the Remote Desktop Users group does not have this right, you must be granted this right manually.

I really don't want to reboot into Windows 7 or run a VM just to RDP to work. Thanks in advance.

share|improve this question
    
Does the RDP client in Windows XP or older work? Might be a new security feature they now require. I know when I use RDP from Vista/7 to XP it warns that it's unable to verify the computer since XP lacks some new security feature added in Vista. There might be a registry tweak to fix Window 7 SP1. –  penguin359 Apr 7 '11 at 1:56
    
Great question. I'll fire up a VM soon and load up XP. I don't have any XP machines anywhere in my near circle at this point. –  Dan Apr 9 '11 at 17:20
    
Hmmm, I installed XP SP1 on a brand new VM and did no updates whatsoever. It connected fine. Very odd. –  Dan Apr 17 '11 at 19:17
    
Try rdesktop or grdesktop to compare. –  penguin359 Apr 17 '11 at 21:36
    
I have used the default Terminal Services on Ubuntu to check with the same result. –  Dan May 12 '11 at 22:58
add comment

3 Answers

On the Windows 7 system, to to Control Panel > System and Security > System and choose Remote Settings.

In the Remote Desktop dialog, choose Allow connections from computers running any version of Remote Desktop (less secure)

share|improve this answer
    
This is the answer I was going to give. –  djangofan Apr 23 '12 at 23:33
add comment

I'm also having trouble getting Remmina to log into Windows 7 SP1+. The specific Win 7 machine I'm trying to log into over RDP is a VMWARE 7.1.4 Virtual Machine. I used to log into my XP machine over RDP so I could have sound on my thin client workstation. Which is one really cool leg up on VNC. I also think RDP is a smidge faster than VNC. I'm not sure if NX supports sound but it seems to be even more of a turd sandwich to config. I think NX uses x11 network transparency which kinda precludes it from working as a server on the windows end although it sounds possible to run it the other direction. If the major distros ever switch to Waylan or whatever over x11 alot of that core functionality will be lost.

I think the RDP problem stems from a version change. I've heard that win 7 uses a different version of RDP called RDPv5. The terminal server client offers this newer protocol but I was unable to achieve anything resembling success. I know I have RDP enabled on my win 7 box (though there are less options) and people claim the firewall automatically configures itself. I don't remember having this much trouble with xp RDP and Remmina running on 10.10. I'm going to build a new xp VM to test but in the meantime if anyone has any suggestions or explanations let me know. This is really kinda frustrating.

share|improve this answer
    
I fully believe you are correct about the version change. What it doesn't explain is why XP - completely fresh and completely unpatched - would connect with no issues. –  Dan May 12 '11 at 22:57
add comment

Disable FIPS on your Windows 7 box. I had the same issue when using Linux Thin Clients to RDP into my Svr2008r2 and Win7 Blades. Disable FIPS on your Win7 box by opening run and typing "gpedit.msc" next you will browse to "Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options" once there open "System cryptography: Use FIPS compliant algorithims for encryption, hashing, and signing" select "Disabled" and click "OK" then open run agian and type "gpupdate /force" and then hit enter. a cmd window will pop up for a second it may or may not give you a prompt to hit yes or no to restart before it closes. if you recieve the prompt restart your Win7 box, if you do not recieve the prompt restart your Win7 box anyways. when it comes back online try to RDP again, as long as you have configured your computer to to accept incoming RDP it should work. If not check your fire wall settings and enusre that RDP incoming connections are allowed. this can be done via wizard or gpedit.msc.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.