Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am upgrading my Fedora OS to the latest version 20 as the current one is nearing end of life. Fedora introduces a new upgrade method called FedUp that allows user to perform an upgrade over the network. I followed the instructions in there and everything went smoothly with no errors in the fedup log:

# fedup --network 20
setting up repos...
getting boot images...
.treeinfo.signed                                              | 2.0 kB  00:00:00
setting up update...
finding updates 100% [==========================================================]
verify local files 100% [=======================================================]
testing upgrade transaction
rpm transaction 100% [==========================================================]
rpm install 100% [==============================================================]
setting up system for upgrade
Finished. Reboot to start upgrade.
Packages without updates:
  btparser-0.25-1.fc18.x86_64
  firstboot-18.6-2.fc18.x86_64
  google-chrome-stable-31.0.1650.63-1.x86_64
  kernel-3.11.10-100.fc18.x86_64
  kernel-3.11.7-100.fc18.x86_64
  kernel-modules-extra-3.11.10-100.fc18.x86_64
  kernel-modules-extra-3.11.7-100.fc18.x86_64
  libgssglue-0.4-1.fc18.x86_64
  mysql-connector-c++-1.1.2-1.fc18.x86_64
  mysql-workbench-5.2.47-2.fc18.x86_64

Upon reboot, I encountered three errors:

Failed to start Load Kernel Modules.
Failed to start IPv6 firewall with ip6tables.
Failed to start IPv4 firewall with iptables.

After logging in and upon further examination with lsmod, I notice that several modules are missing, preventing the network from working. The missing modules include:

ebtable_nat
ebtables
ip6table_filter
ip6_tables 
microcode
nf_conntrack
nf_conntrack_ipv4
nf_conntrack_ipv6
rt2800lib
rt2800usb
snd
uinput
xt_conntrack
xt_limit

It appears there are many missing modules, preventing me from completing the upgrade to the latest OS version.

Next I tried upgrading to version 19 by running the command fedup --network 19, but it seems to do an upgrade to the same version 20 instead. I also tried upgrading using the non-recommended way from DVD iso file and it generates warnings, advising me not to do so.

I am really fedup. What should I do now?

share|improve this question
3  
+1 for that pun. excellent stuff. –  strugee Dec 30 '13 at 11:01
    
"it seems to do an upgrade to the same version 20 instead." The downloaded files are stored in /var/tmp/system-upgrade and it won't download the F19 ones unless you delete the existing files. –  Burhan Ali Jan 3 at 23:19
    
The name "FedUp" does seem quite ironic ^^ –  Martin von Wittich Jan 23 at 23:34
add comment

1 Answer 1

up vote 1 down vote accepted

Use the latest fedup available for your distro. Check updates-testing for updates.

yum --enablerepo=updates-testing upgrade fedup

Don't try to jump over releases. Use standard distro kernel. Re-enable SELinux if you disabled it. Don't ignore fedup warnings.

I just upgraded two Fedora 19 systems to Fedora 20. One of them was upgraded from Fedora 18 in the past.

share|improve this answer
    
Thanks for the suggestion. I did only sudo yum update fedup fedora-release as per instruction for network installation. As for the rest of your suggestions, I did tried upgrading from 18 to 19 but failed. The kernel is standard. SELinux is not disabled. There are no fedup warnings during the upgrade. I am not sure if having custom partition for /home and /var is a problem. I can't tell now since I have given up and performed a fresh installation long before your answer came. Anyway, I would accept yours as there is no way I can test it again. –  Question Overflow Jan 24 at 2:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.