Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Sometimes the computer won't auto-suspend when the lid has been closed. When this happens re-closing the lid won't make it suspend until next reboot. After the reboot the auto-suspend works again. After a while it stops working again, I haven't been able to determine what changes the state from suspendable to unsuspendable.

In the unsuspendable state "sudo pm-suspend" and "sudo systemctl suspend" don't make it stay suspended.

I'm running a Lenovo X220 with Arch 64 bit.

What should I do/try to make it work as it is supposed to?

EDIT:added journalctl output:

journalctl -xn

-- Logs begin at Sun 2013-08-25 11:05:23 CEST, end at Tue 2014-03-04 20:32:31 CET. --
Mar 04 20:32:06 x220 systemd[1]: systemd-suspend.service: main process exited, code=exited, status=1/FAILURE
Mar 04 20:32:06 x220 systemd[1]: Failed to start Suspend.
-- Subject: Unit systemd-suspend.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- Documentation: http://www.freedesktop.org/wiki/Software/systemd/catalog/be02cf6855d2428ba40df7e9d022f03d
-- 
-- Unit systemd-suspend.service has failed.
-- 
-- The result is failed.
Mar 04 20:32:06 x220 systemd[1]: Dependency failed for Suspend.
-- Subject: Unit suspend.target has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- Documentation: http://www.freedesktop.org/wiki/Software/systemd/catalog/be02cf6855d2428ba40df7e9d022f03d
-- 
-- Unit suspend.target has failed.
-- 
-- The result is dependency.
Mar 04 20:32:06 x220 systemd[1]: Service sleep.target is not needed anymore. Stopping.
Mar 04 20:32:06 x220 systemd[1]: Unit systemd-suspend.service entered failed state.
Mar 04 20:32:06 x220 systemd[1]: Stopping Sleep.
-- Subject: Unit sleep.target has begun shutting down
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit sleep.target has begun shutting down.
Mar 04 20:32:06 x220 systemd[1]: Stopped target Sleep.
-- Subject: Unit sleep.target has finished shutting down
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- Documentation: http://www.freedesktop.org/wiki/Software/systemd/catalog/9d1aaa27d60140bd96365438aad20286
-- 
-- Unit sleep.target has finished shutting down.
Mar 04 20:32:06 x220 sudo[21989]: pam_unix(sudo:session): session closed for user root
Mar 04 20:32:06 x220 kernel: video LNXVIDEO:00: Restoring backlight state
share|improve this question
    
Any log that may be useful? sudo journalctl may give you some. –  Felix Yan Dec 30 '13 at 8:38

1 Answer 1

Mine would suspend but immediately resume. The fix for me was to disable (d) Wake-on-LAN:

$ sudo ethtool -s eno1 wol d
$ sudo ethtool eno1 | grep Wake-on
    Supports Wake-on: pumbg
    Wake-on: d
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.