Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I installed Virtual Box regularly on Arch Linux using pacman:

pacman -S virtualbox

When i run virtualbox from the terminal, the GUI of the program is loaded but I can't use a virtual machine and I get this warning:

The vboxdrv kernel module is not loaded. Either there is no module
         available for the current kernel (3.12.5-1-ARCH) or it failed to
         load. Please reinstall the kernel module virtualbox-host-modules or
         if you don't use our stock kernel compile the modules with

           sudo dkms autoinstall

How to solve the problem?

share|improve this question
3  
Well, have you tried to do what the message suggests? –  Risto Salminen Dec 22 '13 at 21:01

1 Answer 1

up vote 6 down vote accepted

I checked and I already had installed virtualbox-host-modules , then I tried to reinstall it. That wasn't enough. Then I tried the command sudo dkms autoinstall. Dkms isn't installed by default so I had to install dkms package. Then I started the service by typing sudo systemctl enable dkms.service . Then I could try with sudo dkms autoinstall again. I tried starting virtualbox again but I still got an error. Then I tried to manually load to module vboxdrv by typing modprobe vboxdrv . Now virtualbox is working.

share|improve this answer
    
In order to load kernel module automatically at boot, you have to create a file (which IMHO has to have suffix .conf) to /etc/modules-load.d/, and put the name of the module to be loaded inside the file. Reference. –  Risto Salminen Dec 22 '13 at 21:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.