Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

After running a system update pacman -Syu with the testing repo not commented, my computer no longer boots. It shows the udev loading, then shows a black screen with a cursor blinking in upper left. I cannot type, or switch tty. What logs should i look at for help? When Looking at verbose boot, it says

/bin/sh cant access tty

and I can't type anything at the prompt.

share|improve this question

migrated from stackoverflow.com Apr 5 '11 at 2:24

This question came from our site for professional and enthusiast programmers.

    
Is there a boot option for safe mode, single user, or failsafe? If you can get to the kernel command-line, try adding single or init=/bin/sh to the command-line. –  penguin359 Apr 5 '11 at 4:53
    
Look at this question and see if you can still boot into single user mode –  phunehehe Apr 5 '11 at 5:39
    
Are you using AMD proprietary drivers? –  Miro Apr 11 '12 at 19:38

2 Answers 2

This is how I fixed this problem :

I've booted into an arch installation CD and mounted my root partition under /mnt/arch.

mkdir /mnt/arch
mount /dev/sda4 /mnt/arch

I then ran the following commands:

cd /mnt/arch
mount -t proc proc proc/
mount -t sysfs sys sys/
mount -o bind /dev dev/

I then issued the chroot command and configured my network:

chroot . /bin/bash
dhcpcd eth0

I'm not sure if all of these commands are required, but I didn't feel like continuously rebooting/chrooting, so I did them all at once and it fixed the issue we both were having:

pacman -Syy
pacman -Syu
pacman -S udev
pacman -S mkinitcpio
mkinitcpio -p linux
reboot

Remove the CD or USB drive and ta-da! Now, I'll be honest and admit that I don't fully understand this fix, but I hope it helps. Some of the posts also suggested doing a “pacman -S linux”, however that was not necessary for me.

share|improve this answer

Hopefully you can still boot into single user mode if the problem is only with the display. Otherwise you boot a live CD, mount your drive(s) and then chroot to gain access to your system.

After that the first thing you should do is to check /var/log/pacman.log to see what may have broken your system. I would suspect an update to xorg or the kernel to cause problems like this. What to do next depends entirely on the package to be fixed.

Please forgive if I'm mistaken, but perhaps you missed the on-screen message that Pacman output when you performed the upgrade. Those are generally important, especially to a rolling release distro like Arch. To quote the ArchWiki:

It is essential that users read all information output by pacman and use common sense.

share|improve this answer
    
Thanks, I am not able to boot into Single User Mode, but i will look at the pacman log. –  VIshnu Apr 5 '11 at 21:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.