Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm currently using Debian 6 with Xfce desktop, and I can't find any setting to make Thunar sort files properly; i.e., by ASCII order. I haven't been able to turn up anything via search engines either. Is there a setting in some config file somewhere that will do this?

share|improve this question
    
Do you really mean ASCII order?.. That would put A-Z before a-z with [ \ ^ ] _ ` between them... Or do you mean that the Latin alphabetic characters sort together and the symbols sort higher or lower than the alphabetic characters (instead of =A mixing in with all the A entries?... btw. I don't know how to do it for Xfce, and I gave up looking for a solution to this Latin Alphabet collation order in nautilus... I found that 'PCMan File Manager' sorts all the symbols to the top (the rest got to the bottom) and is case insensitive. but I just got used to nautilus :) –  Peter.O Apr 4 '11 at 12:52
    
@fred.bear: I definitely want the symbols higher than alphabetic characters, and I'd prefer A-Z to be distinct from a-z, and digits before letters, and digits in order. Right now Thunar is doing insane stuff like 5.txt coming before 030A.txt and it makes it hard to know where in a directory a given file will be. –  Wolf Apr 4 '11 at 13:06
    
Yes, it's a real pain (similar and worse with nautilus; at least Thunar seems to treat symbols "normally").. The idea behind the number thing, is to be "user friendly" and sort numbers according to their numeric value, rather than by the "byte" value... It has some office/home freindly(?!#@) algorithm which looks a leading numerics of text-segments (not just the fist segment)... I'll be watching to see how this pans out ... good luck :) –  Peter.O Apr 4 '11 at 13:26
add comment

2 Answers 2

The normal thing to try is setting LC_COLLATE=C in your environment, but according to Debian bug 436524, Thunar does not respect that setting.

In that bug, the suggestion is to set MiscCaseSensitive to True in ~/.config/Thunar/thunarrc.

I don't know if that sorts symbols first or not, but it might help.

share|improve this answer
add comment

I click on the column header, "Name", and it sorts alphanumerically. You could go into Preferences and unselect "Sort folders before files" to have the entire list sorted (instead of grouped).

share|improve this answer
    
No, that still doesn't sort properly...still getting '5' sorted before '0A' and the like. –  Wolf Apr 5 '11 at 13:32
    
It sorts '0A' before '5' in Thunar 1.0.2. Make sure that the sort is the correct direction. The default may not sort them 'correctly', but after sorting, it is correct. –  Arcege Apr 7 '11 at 1:24
    
I should have been more clear: the '5' in my example above should actually be 5 followed by non-digit characters. Bare '5' does after '0A'. But it also sorts '5' after '05c', and '01' after '0A'. And yes, the sort is in the correct (ascending) direction. –  Wolf Apr 7 '11 at 20:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.