Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm running Openbox 3.5.2 on Fedora 20. For extra comfort (font rendering, tap-to-click, ...), I used to let gnome-settings-daemon run in the background.

Now since upgrading to the F20 beta, my mouse cursor is disappearing right after executing /usr/libexec/gnome-settings-daemon. That is it visually disappears; I am still able to click on things. But the impact on usability is unbearable nonetheless.

At first I thought compton were at fault, which I installed fresh out of koji. But removing it from my autostart doesn't change things for the better. The mouse is just fine in Gnome itself. There's nothing suspicious in .xsession-errors as far as I can tell. I'm really out of ideas right now.

Relevant system info:

$ rpm -q openbox compton gnome-settings-daemon
openbox-3.5.2-2.fc20.x86_64
compton-0-0.3.20121218g75aec17.fc19.x86_64
gnome-settings-daemon-3.10.2-3.fc20.x86_64
$ uname -sr
Linux 3.11.10-301.fc20.x86_64

The machine itself is a X121e Thinkpad with a E-450 APU, powered by the OSS radeon driver.

share|improve this question
    
I experienced the same problem on Ubuntu 13.10 with Openbox 3.5.2-3 and gnome-settings-daemon 3.8.5-0ubuntu9. Your answer below solved it! –  MDCore Jan 23 at 8:52
add comment

1 Answer

up vote 2 down vote accepted

After further investigation, this post in the Arch forums revealed the answer. I used dconf-editor to navigate to org/gnome/settings-daemon/plugins/cursor and unticked the active setting. gnome-settings-daemon is behaving perfectly well now.

share|improve this answer
1  
thank you for this; you could also use $dconf write /org/gnome/settings-daemon/plugins/cursor false in case it's not possible to get a GUI (dconf-editor). –  ILMostro_7 Jan 26 at 20:59
    
Ah, that's good to know. Thanks a lot! –  DaSourcerer Jan 27 at 8:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.