Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

How to reproduce:

  1. ssh -X user@host firefox (or some other X application).
  2. Maximise the window.
  3. Close the application.
  4. Open the application in Awesome WM (tried only locally, but should also work remotely).

Result: The window is still maximised.

Since I never use the maximise functionality in Awesome, and often use it in other window managers, I'd like to unset the maximisation whenever I open X applications in Awesome.

I tried this:

{ rule = { class = "Firefox" },
  properties = { tag = tags[math.min(2, screen.count())][2],
                 maximized_vertical = false, maximized_horizontal = false } },

Firefox does start in tag 2, but it's still maximised. Any idea how to unset the maximisation, for Firefox specifically, but even better for all X applications?

share|improve this question
    
I suspect that Firefox deliberately sidesteps WM hints. If you can't find a better way, consider a timed trigger that unmaximizes Firefox. –  Gilles Dec 17 '13 at 23:38
1  
Firefox is not the only application to preserve its own window settings on exit (for example, the Pan newsreader does this). It looks an awful lot like there's a race condition between Awesome setting up the window, and the application restoring its saved settings. As such, you may be stuck doing it with a timed trigger as the previous commenter noted, or doing it by hand (the default key mapping for toggling window maximization in Awesome is MOD + m). –  ewhac Jan 5 at 1:45
1  
Thanks both! @ewhac, your comment could be converted to an answer. Even better if you know how to create a timed trigger in Awesome. –  l0b0 Jan 5 at 9:45

1 Answer 1

up vote 1 down vote accepted

Converted Comment from @ewhac into an answer:

Firefox is not the only application to preserve its own window settings on exit (for example, the Pan newsreader does this). It looks an awful lot like there's a race condition between Awesome setting up the window, and the application restoring its saved settings.

As such, you may be stuck doing it with a timed trigger as the previous commenter noted, or doing it by hand (the default key mapping for toggling window maximization in Awesome is MOD + m).

share|improve this answer
    
@ewhac: you can post another answer, then I will delete this one –  rubo77 Oct 8 at 16:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.