Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

First, I'm not an expert in Linux but I can fairly move and play around with the OS.

The problem in short is, I was able to find wireless networks, but when I try to authenticate it, network-manager keeps on asking me for my password. So it seems like it's not able to authenticate at all.

In Windows 7 everything's working OK.

So what i've done so far is…

  • I have installed firmware-iwlwifi_0.28_all.deb and was able to detect wireless networks
  • I reconfigured my wifi to wpa2 personal, it does not work. I reconfigured it to use wep 128, it doesn't work either
  • I tried to install ubuntu, and it poses the same problem :(

Here's my PC information:

Asus K42JA. I used the 64 bit installer of Debian Live 6.0.1 and Ubuntu 10.10

Can you help me with this? I can provide you log information, but I don't know where to find them. :(

UPDATE: here's the content of my /etc/network/interfaces.

auto lo
iface lo inet loopback

lsmod (iw* related information)

iwlagn   73139   0
iwlcore  77810   1   iwlagn

here's what's inside daemon.log. Hope you can help me fix this problem. I just bought this laptop :(

Apr  4 18:43:07 sophia NetworkManager[1849]: <info> (wlan0): supplicant connection state:  associating -> disconnected
Apr  4 18:43:07 sophia NetworkManager[1849]: <info> (wlan0): supplicant connection state:  disconnected -> scanning
Apr  4 18:43:08 sophia wpa_supplicant[1879]: Trying to associate with 00:24:01:1a:48:35 (SSID='Funshine' freq=2437 MHz)
Apr  4 18:43:08 sophia NetworkManager[1849]: <info> (wlan0): supplicant connection state:  scanning -> associating
Apr  4 18:43:17 sophia NetworkManager[1849]: <warn> Activation (wlan0/wireless): association took too long.
Apr  4 18:43:17 sophia NetworkManager[1849]: <info> (wlan0): device state change: 5 -> 6 (reason 0)
Apr  4 18:43:17 sophia NetworkManager[1849]: <warn> Activation (wlan0/wireless): asking for new secrets
Apr  4 18:43:17 sophia NetworkManager[1849]: <info> (wlan0): supplicant connection state:  associating -> disconnected
Apr  4 18:43:18 sophia wpa_supplicant[1879]: Authentication with 00:00:00:00:00:00 timed out.
share|improve this question
    
Could you paste your /etc/network/interfaces, minus the passwords of course? :-) Also, the relevant parts of lsmod. What tools are you using to manage the wireless? –  Faheem Mitha Apr 3 '11 at 14:41
    
not much information... updated the details above. –  Marc Vitalis Apr 3 '11 at 14:51
    
added daemon.log details –  Marc Vitalis Apr 4 '11 at 18:49
    
consider trying also with /etc/network/interfaces. It might help to debug the problem. –  Faheem Mitha Apr 4 '11 at 19:27
    
I already tried /etc/network/interfaces, and still no sweet glory from it. I even switched to wicd... :( –  Marc Vitalis Apr 5 '11 at 2:24
add comment

2 Answers 2

If that is really the entire content of /etc/network/interfaces, you need to add your wireless interfaces there. You didn't state what methods you are using to manage the wireless, but whatever it is is clearly not writing to /etc/network/interfaces, which is necessary, as far as I know. This file is where all the network interfaces and configuration information, including passwords, is defined. See any Debian networking tutorial. First take a look at man interfaces.

This network tutorial looks relevant. You'll need to add wlan0 to your /etc/network/interfaces with appropriate configuration. They left that part out.

share|improve this answer
    
network-manager is the one managing my connection, in my other laptops, i didn't configure anything in my /etc/network/interfaces. if that's the case, i'll to put something in it and will let you know. –  Marc Vitalis Apr 3 '11 at 21:02
    
With network manager, you don't need to configure /etc/network/interfaces unless you'd rather have it managed by the system and not rely on a user logging in to be online. I might do that for a stationary server, but probably not for a mobile laptop or even a desktop. –  penguin359 Apr 3 '11 at 21:07
    
@Marc: I don't know anything about network-manager, but are you saying that you have successfully used it to configure your network with your other laptops without writing anything to /etc/network/interfaces? If so, I'm surprised. EDIT: having looked at the documentation, apparently that is how it works. However, if it not working for you, using the standard tools is a reasonable alternative, imo. –  Faheem Mitha Apr 3 '11 at 21:09
    
@penguin: I see. Personally, I prefer to do things as transparently as possible, not use some magic piece of software. But your mileage may vary. –  Faheem Mitha Apr 3 '11 at 21:15
1  
@penguin: after a little googling, this might be a buggy driver. Have you tried with a newer kernel? Are you currently using the default 2.6.32? –  Faheem Mitha Apr 4 '11 at 19:31
show 5 more comments
up vote 1 down vote accepted

It is indeed a buggy driver paired with old kernel. Using the latest kernel (2.6.38) solves the problem.

I installed Ubuntu 11.04, and everything is normal again.

Edited:

Trying to improve my answer here. Intel Wireless 1000 BGN stopped working after 2.6.38. Apparently there is a setting in iwlwifi needed to deactivate for it to work again.

To fix this, create/edit any file under /etc/modprobe.d/ (i.e. /etc/modprobe.d/iwlwifi.conf).

Then, add this in the end.

options iwlwifi bt_coex_active=0

For more information regarding this, refer here or here.

share|improve this answer
    
Thanks for the help everyone. –  Marc Vitalis Apr 7 '11 at 2:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.