Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

My current Xorg configuration is freezing the machine (and text based terminals don't seem to work). Is there a way (e.g. holding down a hot-key) I can prevent the loading of X at boot time?

I cannot access the terminal at this time.

share|improve this question

migrated from serverfault.com Dec 14 '13 at 19:01

This question came from our site for professional system and network administrators.

    
Sometimes it seems like the console is not working but the reason is that you on a virtual terminal with no output. Did you try to ctrl-alt-f1,2,3 to other terminals after booting? –  vanthome Dec 13 '13 at 19:37
    
Yes- these don't seem to work, although pressing the ACPI power button does produce a crash report on the screen (although its still unresponsive from the keyboard). –  chrism2671 Dec 14 '13 at 11:13
    
You can't init 1 or init 3 from your boot loader? Either Grub or Lilo. This seems like it would be the reasonable thing to do. –  vgoff Dec 15 '13 at 19:44

1 Answer 1

When you get to the GRUB menu while starting up (I am assuming you use GRUB although LILO should work exactly the same), look and see if there is a "text only" option. I am not sure about Xubuntu, but many other distros offer this. If not, look for one with "(safe boot)" or similar at the end (which I know xubuntu does have). This often won't load a gui, and if it does it will make every attempt to get it to work. This should at least get you far enough in to change the settings that you need to change.

If none of this works, you will have to manually enter single-user mode. Press e at the GRUB menu, ant you will come up with a list of configs. Find your normal config (which should look something along the lines of linux /boot/vmlinuz root=/dev/sda4 ro quiet splash). Remove the splash and quiet if they are there (to disable the splash screen and enable verbose mode) and add single instead. Press Ctrl+X to boot this configuration. A lot of text will scroll past the screen (remember - verbose mode?) and then you will be left at a root (technically single-user) shell. From there you should definitely be able to edit whatever file you need to get X working again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.