Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I can't connect to a WiFi network. I tried various methods such as wpa_supplicant and wicd. At the moment I'm trying netctl.

When I enter the command: systemctl --type=service I see the following errors:

enter image description here

netctl start wireless-home

Job for netctl@wireless\x2dhome.service failed. See 'systemctl status
netctl@wireless\x2dhome.service' and 'journalctl -xn' for details.

This is the profile file for wireless-home:

Description='A simple WPA encrypted wireless connection'
Interface=wlan0
Connection=wireless
Security=wpa
IP=dhcp
ESSID='Pruthenia 3.OG'
Key='XXXXXXXXXX'

systemctl status netctl@wireless\x2dhome.service

netctl@wirelessx2dhome.service - Networking for netctl profile wirelessx2dhome 
Loaded: loaded (/usr/lib/systemd/system/netctl@.service; static) 
Active: inactive (dead) Docs: man:netctl.profile(5)

journalctl -xn output -->

Dec 12 08:01:01 webcampi CROND[2765]: pam_unix(crond:session): session closed for user root
Dec 12 09:01:01 webcampi crond[3490]: pam_unix(crond:session): session opened for user root by (uid=0)
Dec 12 09:01:01 webcampi CROND[3491]: (root) CMD (run-parts /etc/cron.hourly)
Dec 12 09:01:01 webcampi CROND[3490]: pam_unix(crond:session): session closed for user root
Dec 12 10:01:01 webcampi crond[4216]: pam_unix(crond:session): session opened for user root by (uid=0)
Dec 12 10:01:01 webcampi CROND[4217]: (root) CMD (run-parts /etc/cron.hourly)
Dec 12 10:01:01 webcampi CROND[4216]: pam_unix(crond:session): session closed for user root
Dec 12 11:01:01 webcampi crond[4941]: pam_unix(crond:session): session opened for user root by (uid=0)
Dec 12 11:01:01 webcampi CROND[4942]: (root) CMD (run-parts /etc/cron.hourly)
Dec 12 11:01:01 webcampi CROND[4941]: pam_unix(crond:session): session closed for user root

How can I fix this?

share|improve this question
    
Your journal output are useless: crond is used by your system to schedule task. Not related to your problem. I guess your interface name is wrong. Are you sure you need the single quotes around your ESSID and key? If all fails, try directly wpa_supplicant and dhcp. These will be more verbose. –  Gael Dec 13 '13 at 11:26
    
Yes i am sure that the inteface name is correct wpa_supplicant is working though to thigs are add, i cant get dhcp working and wpa_supplicant stopps working afther a few minutes, that why i wanted to switch to netctl –  user275941 Dec 13 '13 at 11:33
    
netctl is using wpa_supplicant and dhcpd. Solve your problem with them first and then netctl should work as expected. –  Gael Dec 13 '13 at 11:45
    
Try to remove the hyphen from the name of your profile, e.g. rename it for example to wirelesshome. There's notice about it in archwiki page about netctl (that's also netctl's wiki, because netctl is arch project). –  Risto Salminen Dec 23 '13 at 17:32
add comment

2 Answers 2

Try connecting with wifi-menu and if you get it to work; save the config with wifi-menu -o. netctl wiki

share|improve this answer
add comment

The problem is most likely due to netctl not liking hyphens in its profile files.

Excerpt from there:

Tip: As mentioned in the forums, because systemd treats hyphens in a special way, using '-' in a profile name may result in connection drop issues.

Another excerpt (this has value only if you have created your profile file with wifi-menu -o):

Warning: Attempting to use wifi-menu -o to generate a profile file in /etc/netctl/ with a '-' in name will likely fail. Renaming the file is recommended

As a solution, I'd suggest you to remove the hyphen from the name of your profile file, so the name of the profile file would end up to be for example wirelesshome or wireless_home.

After you've done that, you should be able to start your profile with netctl start wirelesshome (or whatever the profile name is), and then enable it (if you want it to start at boot) with netctl enable wirelesshome. Also, if you have enabled your previous profile file before, remember to disable it before enabling the new profile with netctl disable wireless-home.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.