Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have followed the following steps to get Optimus/Bumblebee configuration running on Fedora 20 (fresh basic installation) on my brand new laptop (based on msi barebone MS-16GC).

I have listed all steps, very similar to this link

The end result has x not booting, I can boot to a terminal. I feel I am stuck at the last step, please help:

These are the steps I have taken

1) My BIOS does not support switching on/off the nvidia card 2) Fedora 20 was installed from live cd - kernel/software updated - kernel-devel and kernel-headers are installed, along with gcc-c++ and lshw. NVIDIA display driver version 331.20 is downloaded, but not installed yet. 3) Subsequent current kernel: 3.11.10-301.fc20.x86_64 4) lspci gives two devices of intrest

00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
01:00.0 3D controller: NVIDIA Corporation GK106M [GeForce GTX 765M] (rev a1)

lshw shows that the NVIDIA card uses nouveau

 *-display

        description: 3D controller
        product: GK106M [GeForce GTX 765M]
        vendor: NVIDIA Corporation
        physical id: 0
        bus info: pci@0000:01:00.0
        version: a1
        width: 64 bits
        clock: 33MHz
        capabilities: bus_master cap_list rom
        configuration: driver=nouveau latency=0
        resources: irq:16 memory:f6000000-f6ffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:e000(size=128) memory:f7000000-f707ffff

*-display
     description: VGA compatible controller
     product: 4th Gen Core Processor Integrated Graphics Controller
     vendor: Intel Corporation
     physical id: 2
     bus info: pci@0000:00:02.0
     version: 06
     width: 64 bits
     clock: 33MHz
     capabilities: vga_controller bus_master cap_list rom
     configuration: driver=i915 latency=0
     resources: irq:43 memory:f7400000-f77fffff memory:b0000000-bfffffff ioport:f000(size=64)

In preperation of driver NVIDIA driver install

5) blacklist nouveau, by creating a file blacklist.conf in /etc/modprobe.d/ with the line `

blacklist nouveau

Reboot

mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r)-nouveau.img
dracut /boot/initramfs-$(uname -r).img $(uname -r)

Reboot

And in /etc/default/grub I added rdblacklist=nouveau to GRUB_CMDLINE_LINUX Followed by the grub2-mkconfig > /boot/grub2/grub.cfg command

Reboot the computer (just to be sure)

lshw now outputs the following - no sign of nouveau is disabled - device is UNCLAIMED.

 *-display UNCLAIMED
                description: 3D controller
                product: GK106M [GeForce GTX 765M]
                vendor: NVIDIA Corporation
                physical id: 0
                bus info: pci@0000:01:00.0
                version: a1
                width: 64 bits
                clock: 33MHz
                capabilities: bus_master cap_list
                configuration: latency=0
                resources: memory:f6000000-f6ffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:e000(size=128) memory:f7000000-f707ffff
 *-display
             description: VGA compatible controller
             product: 4th Gen Core Processor Integrated Graphics Controller
             vendor: Intel Corporation
             physical id: 2
             bus info: pci@0000:00:02.0
             version: 06
             width: 64 bits
             clock: 33MHz
             capabilities: vga_controller bus_master cap_list rom
             configuration: driver=i915 latency=0
             resources: irq:43 memory:f7400000-f77fffff memory:b0000000-bfffffff ioport:f000(size=64)

6) Next I create a file in my home directory called .xinitrc containing following lines

xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto
exec gnome-session

7) Then I create a file in /etc/X11 called xorg.conf2 containing following data

Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia"
    Inactive "intel"
EndSection

Section "Device"
    Identifier "intel"
    Driver "intel"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection

Section "Device"
    Option "ConstrainCursor" "no"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
#Comment to output using hdmi cable  
 Option "UseDisplayDevice" "none"
EndSection

8) Time to install the drivers

/* I get stuck here */

Type chmod +x NVIDIA* And then ./NVIDIA*

Next I move xorg.conf2 to xorg.conf

This installs fine, but when rebooting all I get is a black screen, I can log in to ttyl when I type startx from command line same problem, just black screen.

Please help!

share|improve this question
add comment

1 Answer

Please have a look at dmesg, and see whether your kernel is refusing to load an unsigned module : That's going to be a problem if you're booting with UEFI and Secure Boot enabled.

For me, turning off secure boot, and following the instructions at https://fedoraproject.org/wiki/Bumblebee#fedora20 did the trick. I also wrote up the process at http://mdda.net/oss-blog/2014-06/install-nvidia-optimus-on-FC20-acer-notebook/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.