Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

My main desktop has Mint 14 and I approached it via SSH from another computer, because I didn't have a screen on the Mint one. Then I tried to start teamviewer just I order to launch its desktop session remotely. I started the teamviewer and everything ran fine, but then I tried to stop this application from the terminal and this is what happens:

Checking:

x@x-pc /opt/teamviewer8 $ ps -ef | grep team
root      1567     1  0 20:55 ?        00:00:00 /opt/teamviewer8/tv_bin/teamviewerd -f
x         2892     1  0 21:41 ?        00:00:00 /opt/teamviewer8/tv_bin/wine/bin/wineserver
x         2914  2822  0 21:48 pts/0    00:00:00 grep --colour=auto team

Using one-liner just to feel myself more hacker like :)

sudo for i in `ps -ef | grep team | awk {'print $2'} | xargs`; do kill -9 $i; done

Checking again:

x-pc teamviewer8 # ps -ef | grep team
root      3003     1  0 21:50 ?        00:00:00 /opt/teamviewer8/tv_bin/teamviewerd -f
root      3009  2957  0 21:50 pts/0    00:00:00 grep --colour=auto team

Killing again:

x-pc teamviewer8 # ps -ef | grep team
root      3003     1  0 21:50 ?        00:00:00 /opt/teamviewer8/tv_bin/teamviewerd -f
root      3011  2957  0 21:57 pts/0    00:00:00 grep --colour=auto team
x-pc teamviewer8 #
x-pc teamviewer8 #
x-pc teamviewer8 #
x-pc teamviewer8 #
x-pc teamviewer8 # kill -9 3003
x-pc teamviewer8 #
x-pc teamviewer8 #
x-pc teamviewer8 # ps -ef | grep team
root      3012     1  2 21:57 ?        00:00:00 /opt/teamviewer8/tv_bin/teamviewerd -f
root      3017  2957  0 21:57 pts/0    00:00:00 grep --colour=auto team
#########################################

No matter how many times I killed it, it receives new PID. How can I kill it?

share|improve this question
1  
(For your one-liner: look into pgrep/pkill) –  Mat Dec 7 '13 at 20:13
2  
Try killall -9 teamviewer. If doesn't work please show the output of pstree. –  mavillan Dec 7 '13 at 20:42

5 Answers 5

If you do

teamviewer --daemon stop

you stop it once but it starts again upon next boot, but with

sudo update-rc.d teamviewerd remove

you also prevent it from starting itself on bootup

share|improve this answer
    
Thanks, this worked perfect for me. –  jefffan24 Feb 13 at 16:08

Try to stop systemd service (if you use systemd):

# systemctl stop teamviewerd
# systemctl disable teamviewerd
share|improve this answer
    
No, actually I do not use it. –  Dread X Dec 7 '13 at 21:12

Try the following:

# teamviewer --daemon stop
share|improve this answer

I use Ubuntu 12.04, but I do not think the process will be different using other versions of Ubuntu.

TeamViewer screen sharing is my choice to replace the "TOO BLURRED TO READ" Skype screen share. The window sizes are about the same on my screen, but I can now read the print whereas the Skype blur makes reading impossible.

Please note that although TeamViewer runs under Wine, there are many native scripts that also run.

There has been some notice of the "TeamViewer remote control daemon" (teamviewerd) remaining active after the user is finished using and terminated TeamViewer. Respawning is also used to make sure it stays active. The easiest solution is to reboot or logout after making sure the "start with system" check box is cleared. When you log in, TeamViewer should not start and the daemon should not appear.

If you want a solution that does not require logging out, you must delete the respawn commands from the configuration file.

In the terminal, enter:

gksudo gedit -s /etc/init/teamviewerd.conf

Delete the two lines:

respawn

respawn limit 5 60

Save the file. Do not worry about the teamviewerd.conf.bak file.

Now that respawn is disabled, ending the daemon will end it. I did not notice anything unusual in the way TeamViewer functions with the modified script.

Note: the changes will not initially take effect until TeamViewer reads the script. Reboot, log-out, or terminate and restart TeamViewer are options. I only tried log-out and it worked for me. I did not try the other options as I modified the script only once.

share|improve this answer

To disable Teamviewer on startup :

teamviewer --daemon disable
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.