Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm managing almost 100 lab PC's running Fedora 19. It's difficult to manage because it seems like no where that I can display the hostname at the login screen.

GDM version: gdm-3.8-3.2

share|improve this question

closed as unclear what you're asking by terdon Apr 8 at 13:16

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

    
You have to edit the .bashrc file. What is the output you get when you run the command echo $PS1? – Ramesh Dec 4 '13 at 16:25
    
Assuming you're using graphical logins, you should be able to configure the display manager to show information about the host. Which DM are you using? – user13742 Dec 4 '13 at 16:27
    
What login screen? Text or GUI? You can display anything you like on either but you need to tell us how you are connecting to these machines and where you would like to see the hostname. – terdon Dec 4 '13 at 16:32
    
Hi Herman. Its gdm-3.8-3.2 – Shâu Shắc Dec 4 '13 at 16:33
1  
In my Fedora 19 there is no directory /etc/gdm3 – Shâu Shắc Dec 4 '13 at 17:31

you can do

cat > /etc/dconf/db/gdm.d/01-mysettings <<EOF
[org/gnome/login-screen]
banner-message-enable=true
banner-message-text='<PUT HOSTNAME HERE>' 
disable-restart-buttons=false
disable-user-list=false
EOF

rm /etc/dconf/db/gdm
dconf update
share|improve this answer
    
I need a solution that can be applied for 100 lab PC. So by putting that hostname like this is very ugly Also, I disable user list, so virtually the banner message doesnt display at all. I dont know why – Shâu Shắc Dec 13 '13 at 10:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.