Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

One of my customers uses a machine running CentOS 6.4 with Gnome 2.28.2. Whenever he plugs a USB memory stick or external hard drive into the machine he gets an error pop-up that simply states Unable to mount <filesystem name>. Not Authorized.. We've tried devices formatted with FAT and EXT4. The only way I've found to mount these devices is by running palimpsest as root. Even then, the user cannot write to the file system. I suspect this is permissions related.

So, my question is how can we restore the default behaviour for standard users where USB devices can be mounted and used normally?

share|improve this question

2 Answers 2

I cannot confirm this will solve your problem, because I don't have a CentOS 6.4 server with X11. However, according to Sombrero Roja's KB:

In the desktop environment, udisks system manages the automatic mounts of the device.

udisks defines the policy for devices in /usr/share/polkit-1/actions/org.freedesktop.udisks.policy.

To override the policy, create a pkla file as follows:

/var/lib/polkit-1/localauthority/10-vendor.d/20-disk.pkla:

[Enable mount]
Identity=unix-group:*
Action=org.freedesktop.udisks.filesystem-mount
ResultAny=yes
ResultInactive=yes
ResultActive=yes

After editing, log into desktop environment again.

You might want to also investigate /apps/nautilus/preferences.

share|improve this answer

Since we don't have the output of your fdisk -l command, the best we can do is guess at the filesystem name. That being said, the mount command should be something similar to this:

mount /dev/sda1 /mnt/

The default behavoir can be changed within the /etc/fstab file. For instance, setting whether the device is mounted at startup, access control, etc.

See more information here:

Items with a user keyword in them allow the user to mount or umount the corresponding device without needing to use sudo or su. Items with auto mount automatically on system startup (and if not present may cause startup problems). Items with rw are mounted read-write.

share|improve this answer
1  
I believe this is not what the OP is asking about ... –  warl0ck Dec 4 '13 at 12:25
    
You're right, warl0ck. As I understand it, any standard user should be able to connect a USB device, have it automatically mounted and write files to it. This isn't the case at the moment. As soon as a device is connected, the user (any user!) receives the 'Not Authorized' error. Please let me know if I can provide any further info to assist. Thanks. –  Dave T Dec 4 '13 at 16:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.