Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running a Linux server (without xwindows or any kind of GUI), with a modern 22" LCD monitor.

Given the huge size of my monitor, I would like to increase the number of rows and columns on my terminal, how can I go about achieving it?

share|improve this question

Add something like "vga=792" to the kernel line in your grub.conf file, usually located in /etc or /boot/grub:

title My Linux OS Name and Kernel Version Number
    root (hd0,0)
    kernel /boot/vmlinuz- ro root=/dev/hda1 quiet vga=792
    initrd /boot/initrd-

You can say vga=ask instead to get a menu on boot, built from a probing process performed by the kernel to see which resolutions are likely to work. I find that there are often other numbers that will work that this method doesn't find.

This is all system-specific. Different video cards will have different supported modes, and kernel build options can open up or close off video mode options. The subsystem that deals with this is called the kernel framebuffer, so if you're compiling custom kernels, be careful not to remove the support your kernel needs to fully support your video card. Most cards can use the VESA FB driver, but another driver specific to your brand of card might open more options.

Also, beware that some parts of this subsystem use hex numbers, and others decimal. You can do the conversion to decimal, as I've done, or you can say something like "vga=0x318" instead.

share|improve this answer
This system is good... but you might want to check to see if your video chip supports KMS (most common in Intel, and ATI, but I won't say it's not in others) if it does you should try enabling it at boot, it will autoresize your VT. – xenoterracide Aug 23 '10 at 6:19

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.