Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Hi I'm on the last step of setting up Whonix physical isolation and can't get the gateway to see the workstation.

I'm confused because on the page linked below where it says 'Host Network' and 'NAT Recommended'. They both advise to replace the same file with different code?

Anyways, the gateway will just tell me something like:

DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 7
No DHCPOFFER received.

Any ideas on how to fix this? I'm using a wired connection.

Site: https://www.whonix.org/wiki/Physical_Isolation

share|improve this question

1 Answer 1

No DHCPOFFER received.

You are probably not using a router with DHCP? In case you're using a modem, you have to manually setup your network connection. How? Same way you would do so when using Debian. How? That's off topic here and that's why that article says advanced Linux users only. You had a working /etc/network/interfaces earlier anyway when you installed Debian, otherwise you wouldn't have been able to connect in the first place.

I'm confused because on the page linked below where it says 'Host Network' and 'NAT Recommended'. They both advise to replace the same file with different code?

You can find that out depending on the context and the titles. If the highest level chapter says for example "Install Whonix-Workstation in a VM", then this has nothing to do with Whonix-Gateway instructions.

The main chapter "How To Install Whonix-Gateway on Hardware (RECOMMENDED)" is probably most important for you. There is a sub chapter "Network Configuration". After running the build script, it may overwrite your network configuration and you may have to fix it. (In case you're not using a DHCP capable router.) There is a backup file /etc/network/interfaces.backup. Just look at how eth0 (the external interface) was configured and copy these settings back to /etc/network/interfaces.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.