Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have recently bought an Acer Aspire E1-572 with NetXtreme BCM57786 Gigabit Ethernet network card. The problem is that currently I cannot see it in ifconfig, but I can see it with lshw:

  *-network UNCLAIMED
       description: Ethernet controller
       product: NetXtreme BCM57786 Gigabit Ethernet PCIe
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi msix pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:b0410000-b041ffff memory:b0420000-b042ffff memory:b0430000-b04307ff

Shortly, I have found this bug: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1242610 and it seems to be exactly my problem. It seems to be solved in this commit http://git.kernel.org/cgit/linux/kernel/git/davem/net-next.git/commit/drivers/net/ethernet/broadcom/tg3.c?id=68273712a19e9107a498a371532b3b3eb6dbb14c

I am using Ubuntu 12.04 so there's a probability that (at some point) the patch will be backported, but I would really like to find (if there is any) a [preferably] stable kernel version that would contain this patch so I would be able to use my eth0.

How would I find a kernel binary that contains a specific commit? Or find whether a specific kernel binary has a given commit?

UPDATE

# uname -a
Linux laptop 3.8.0-33-generic #48~precise1-Ubuntu SMP Thu Oct 24 16:31:16 UTC 2013 i686 i686 i386 GNU/Linux

I installed it using:

apt-get install linux-generic-lts-raring
share|improve this question

migrated from serverfault.com Nov 26 '13 at 23:19

This question came from our site for professional system and network administrators.

    
What's your kernel version? –  mtahmed Nov 27 '13 at 3:22
    
I've updated my question –  s3v3n Nov 27 '13 at 8:26

1 Answer 1

According to the git commit history, the particular commit you identified as containing the fix you needed was merged to the mainline kernel in v3.13-rc1:

$ git describe --contains 68273712a19e9107a498a371532b3b3eb6dbb14c
v3.13-rc1~105^2~360

Unfortunately it seems unlikely that the particular patch would get included into older kernels in the stable development branch as that is generally only done to relatively small and critical fixes for security problems or significant regressions discovered in a given 3.x kernel.

That said, it isn't impossible that the fix would get picked up by distribution maintainers, or you could always apply the patch yourself and build your own kernel.

The Ubuntu kernel sources can be obtained by running:

git clone git://kernel.ubuntu.com/ubuntu/ubuntu-<release>.git

As a sidenote, you might want to install the linux-current-generic package instead of linux-generic-lts-raring as the former will on depend the most recently released generic kernel image and headers, up to 14.04 inclusive.

share|improve this answer
1  
+1 But: "it seems unlikely that the particular fix would make its way into the stable development branch" -> the mainline branch feeds the stable branch, so I'd say unless there is some reason to remove this change, it will be in the stable 3.13 release (which shouldn't be too far away). –  goldilocks Nov 27 '13 at 18:50
    
Perhaps I will try compiling the kernel by myself. As a side note, for some reason I failed to install the linux-current-generic package: pastebin.com/raw.php?i=AZarV7Bx –  s3v3n Nov 27 '13 at 19:27
    
@goldilocks Thanks for your comment. That was poor wording from my part as the question was specifically about backports. Hopefully my edit made the answer more clear. –  Thomas Nyman Nov 27 '13 at 20:10
1  
@s3v3n: The output looks fine to me. Currently, linux-current-generic depends on linux-generic-lts-raring as that is currently the most recent backported kernel image available in Ubuntu. My point was that when the kernel from saucy is backported, linux-current-generic will be changed to depend on that kernel instead, meaning that you will automatically update to that instead, which would not occur if you explicitly install linux-generic-lts-raring. –  Thomas Nyman Nov 27 '13 at 20:15
    
Thank you very much for your input, guys! It indeed makes sense –  s3v3n Nov 27 '13 at 22:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.