Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm running Arch Linux, using the Emerald window decorator. Emerald crashes in the following situations:

  • A window with at least one Chinese character in the title is opened.
  • An open window's title changes to something with at least one Chinese character

When it crashes, it gives the following stderr:

emerald: cairo-scaled-font.c:459: _cairo_scaled_glyph_page_destroy: Assertion `!scaled_font->cache_frozen' failed.

Which is immediately followed with what seems to be a standard C++ error on stdout:

Aborted (core dumped)

A few extra notes:

  • I initially thought this was some problem with CJK encoding. However, it doesn't seem to happen when I load a page with Korean or Japanese in the title. Only Chinese. Of course, it's still entirely possible that some CJK package will fix my problems.

  • Emerald version: 0.8.8

  • Compiz version: 0.8.9

  • Desktop Environment: Mate Desktop 1.6.1

  • Linux Kernel: 3.12.1

  • Nvidia driver version: 331.20

share|improve this question
1  
That's bug. Report it. Assertions in production code imply a problem spot. It may be something in the configuration of the cairo stack, so start by reporting it downstream, to Arch, first. –  goldilocks Nov 25 '13 at 15:37
    
@goldilocks Sounds good. I'll report it on the AUR. –  dotVezz Nov 25 '13 at 15:40

1 Answer 1

Don't know if this helps much, but I saw this same error in Lubuntu. Lxterminal and several other apps would crash. However, xterm ran, and when I tried to launch lxterminal from xterm, I saw that error message.

There is a workaround in Lubuntu. In Preferences->Customize Look and Feel, under the Widgets tab (the default), change "Lubuntu-default" to anything else, such as "Mist".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.