Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am trying to set up a server for my son to play Pocketmine. This is a PHP server and it is running on port 19132. I have opened this port on my router and if I run another server, like a Rails server, then everything is fine. When I try to run Pocketmine, the port is never open. I have the server running now. Here is my netstat output.

Netstat output

You can see the server, it is the first line that is a udp port. I see that it does not have a state of LISTEN. Here is the output from my server.
Server Output

What could be the problem? Why does the udp server not it a state of LISTEN? Does it need to be in a state of LISTEN? What else could be the problem to stop the port from being open? What do I do to trouble shoot this?

share|improve this question
    
I'm pretty sure that UDP never shows listening. Only established when there's an actual active connection. The nature of UDP is that is always listening. –  slm Nov 25 '13 at 3:57

2 Answers 2

up vote 2 down vote accepted

Idea #1 - UDP port forwarding?

Confirm that when you opened this port on your router that you specified either both TCP/UDP or UDP. The types of these ports matters, and can often be overlooked when opening ports on ones firewall/router.

Idea #2 - Port forward on pocketmine realms issue?

I came across this forum post which sounds like exactly the issue you're having. It even shows screenshots that this particular user used to open up the UDP port on his router and he was still not able to get it working.

share|improve this answer

The reason why you don't see LISTEN on the minecraft server port is due to the way the UDP protocol works.

A server that uses the TCP protocol "listens" for a connection so that when a client tries to connect, it will commence a session and transfer data using the TCP/IP protocol. If there is nothing "listening" on a certain port for TCP connections, the protocol itself can generate an error to say that it couldn't connect to a server that was listening on a port.

UDP connections don't have sessions, and as such they don't "listen" for connections. What actually happens is that a UDP packet is sent to that port, and if there is a server receiving packets on that port then the data will be processed. Otherwise if there is nothing receiving packets, then that packet disappears into the void, and no error will be generated on the protocol level.

The fact that you can see the port 19132 on the netstat means that in the UDP world, the server is "listening" for data on that port, which means that the port is actually open.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.