Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm getting this error while running the eggdrop bot, while loading the http.tcl script:

conflicting versions provided for package "http": 2.7.5, then 2.5.2

How do I fix this?

share|improve this question
1  
I don't understand the question. Can you provide some output showing the problem? – glenn jackman Mar 28 '11 at 17:44
3  
More context like OS, and a link to this eggdrop thing would be helpful too. And some information about package http as well, since that is referenced in the error message. – Faheem Mitha Mar 28 '11 at 17:48
    
what is your $auto_path, and show us the command you use to load http.tcl (load, package require, ?) – glenn jackman Mar 28 '11 at 19:41
    
isn't eggdrop a technology used in chat clients to launch various malware, etc (It probably also has a positive use. Maybe 'meeeeeee' can enlighten us.) – shellter Mar 29 '11 at 22:39

The problem is, that the command "package provide http X.Y.Z" is executed twice, but with different version numbers. Have a look in your pkgindex.tcl and fix the version numbers.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.