Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a PC with Intel 4600 graphics and a fresh install of Xubuntu 13.10 64 bit. Any video playback causes the system to freeze up. The audio plays, but the video plays at about 1 frame per second, and the entire system become unresponsive. I am sometimes able to recover with xkill, but often have to switch to a text terminal and reboot.

However, youtube video does work. I even have played video inside a Windows XP virtual machine and it works fine. I've installed the restricted Ubuntu codec package, and VLC, but they have no effect.

It seems there are no Intel graphics for 13.10, and I can't find anyone else complaining of this. Any ideas?

EDIT: I got video to work in a Xubuntu 13.10 VM, and then natively by turning off hardware acceleration in VLC. The system is usable in this state, however, I'd rather not have to worry about any random program crashing the system if it attempts to use hardware acceleration.

Is there some way to turn off hardware acceleration globally?

share|improve this question
    
You say that any video causes the system to freeze, but then go on to say that youtube video works (within all browsers or Chrome and/or Iceweasle/Firefox)? Can you try characterizing the problem a bit more? –  slm Nov 23 '13 at 8:38
add comment

2 Answers

I might be tempted to try the actual drivers from Intel's download site instead of the ones available via the software center. You can find the drivers and installation instructions here:

Also make sure you look through the known issues and warnings on the page for hints/issues related to your particular hardware.

share|improve this answer
    
I had seen that site, however, there doesn't seem to be a package for 13.10, only 13.04. I'd rather not compile from source. –  DaleSwanson Nov 23 '13 at 21:17
    
Well this answers your Q 8-) –  slm Nov 23 '13 at 21:22
add comment
up vote 0 down vote accepted

Well it has been a while, but I fixed this. I switched from the newer SNA to the older UXA.

Edit (or create) the file at:

/etc/X11/xorg.conf.d/20-intel.conf

To include:

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "uxa"
EndSection
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.