Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have been trying to install Linux Mint 16 Petra using a removable USB thumb drive on my laptop, and after multiple attempts, I get the same error every time:

error: file '/boot/grub/i386-pc/normal.mod' not found.
Entering rescue mode...
grub rescue>

I tried following the instructions here, but absolutely none of it helped.

How do I get my computer to boot?

share|improve this question
    
So you can boot from USB, but get the grub error on 'normal' boot. Like the thread you gave a link to, are there initial boot options from USB? –  rickhg12hs Nov 23 '13 at 11:57
    
@rickhg12hs: With the USB thumb drive connected, the only options are to boot from the USB drive or run some memory tests. Nothing that can help the GRUB error. –  Dave M G Nov 23 '13 at 16:02
    
There are no boot options from USB? E.g., BIOS vs UEFI? –  rickhg12hs Nov 23 '13 at 16:20
    
@rickhg12hs: Nope. Should there be? –  Dave M G Nov 23 '13 at 16:23
1  
@rickhg12hs: Maybe... I don't know what's happening right now, but I can't seem to boot from the USB thumb drive now either. I've checked the BIOS settings and I should be able to. It's possible my thumb drive has died, so I'm going to have to get another one to try. –  Dave M G Nov 23 '13 at 19:08

3 Answers 3

up vote 3 down vote accepted

The solution was to boot the computer using the USB stick, and then run Boot Repair, which I only just learned about.

It was easy to install via repository, and the process was very clear. It reported an error, but the computer was able to reboot successfully anyway.

In the GRUB menu, the default option says ubuntu instead of Linux Mint, but I can live with that.

share|improve this answer
2  
Glad you were able to fix it. Waiting for a Mint kernel update or running 'sudo update-grub' may "fix" the grub Ubuntu listing. –  rickhg12hs Nov 24 '13 at 15:09
1  
@rickhg12hs: Thank you for all your suggestions and help along the way. Strangely, the GRUB listing seems to have corrected itself, though I can't be sure why or how. Likely it was something to do with some updates I did with the GUI update manager, but I couldn't tell you exactly what. –  Dave M G Nov 25 '13 at 3:08

Use these lines in menu.lst from grub4dos USb boot:

#  #  #
find --set-root /linuxmint.iso
map (hd0) (hd1)
map (hd1) (hd0)
map --mem /firadisk.img (fd1)
map --mem (md)0x6000+800 (fd0)
map --mem /linuxmint.iso (0xff)
map --hook
dd if=(fd1) of=(fd0) count=1
chainloader (0xff)
#  #  #

PS:

  1. linuxmint.iso work with install of any OS iso

  2. firadisk.iso is a virtual iso(google it)

share|improve this answer
    
1) He doesn't have grub4dos, 2) he isn't trying to boot the iso image, and 3) dd is not a grub command. –  psusi Feb 1 at 18:21

look at diddy manual. He has the command cc there

diddy.boot-land.net/firadisk/files/win_iso_install.htm

also last guide on this page called "Using dd to edit sectors"

http://www.rmprepusb.com/tutorials/grub4dos#TOC-grub4dos-undocumented-commands

then please comment

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.