Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm currently trying to configure my bridge in Debian 7. I do have a working config for IPv4:

auto eth0
iface eth0 inet manual
auto br0
iface br0 inet static
  address xx.xx.xx.131
  netmask 255.255.255.192
  gateway xx.xx.xx.129
  bridge_ports eth0
  bridge_stp off
  bridge_fd 1
  bridge_hello 2
  bridge_maxage 12

iface br0 inet6 static
  address xx:xx:xx::2
  netmask 64
  gateway xxxx::1

But on boot my interface only comes up with a IPv4 address. I also tried adding

up ip -6 addr add xx:xx:xx:2/64 dev br0
up ip -6 route add default via xxxx:1 dev br0

to the IPv4 config. No success either. If I execute the ip -6 commands listed above after the reboot IPv6 works just fine.

Caveat: I'm running a clean minimal install of Debian 7 nothing has yet been added.

share|improve this question
2  
Is IPv6 disabled on the bridge? Please post the result of cat /proc/sys/net/ipv6/conf/br0/disable_ipv6. –  jofel Nov 21 '13 at 13:30
    
hey jofel, the output is 0 –  Momo Nov 21 '13 at 14:31
    
ok, then this is not the problem. –  jofel Nov 21 '13 at 20:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.