Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am new to Linux and have a server running Fedora 19 and need to see the desltop from a Windows 7 machine. I have found a lot of conflicting advice on different methods and have plumped for the xRDP approach following this install and set up method.

However, when I try to connect I get this error: enter image description here

I can log in via SSH using putty and have a command line terminal session but if I try tunneling the SSH connection with TightVNC (following these directions), I get this error: enter image description here

I have no direct access to the actual machine and so cannot see the desktop and therefore cannot follow any of the (plentiful) advice about how to set this up using the GUI controls. The solution will have to be through the command line. I believe the Fedora box is running Gnome3 and I can get a PID for xRDP, so I know that is running.

My gut feeling is that there is a vital step missing from the "how to" instructions I linked above but I don't know what. Any help for this newbie gratefully received!

share|improve this question
    
Since you seem to have RDP running on Fedora, have you tried connecting with 'mstsc' from Windows. –  rickhg12hs Nov 20 '13 at 16:43
    
Yes. Unfortunately that gives me the first fail screenshot. –  MappaGnosis Nov 20 '13 at 16:56
    
Have you tried it with the firewall disabled? –  rickhg12hs Nov 20 '13 at 17:27
    
No but I tried opening a port (I think it was 3389) as per on of the how-to descriptions –  MappaGnosis Nov 20 '13 at 18:06
add comment

1 Answer

up vote 0 down vote accepted

I have a solution to my goal, if not the exact question. Basically I ditched XRDP altogether as I was getting nowhere. It promised to be an easy route to remote desktopping to the server but wasn't. Instead I returned to the VNC via SSH tunnel method and by following this tutorial I managed to get everything working after opening the required ports in the firewall.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.