Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This is what I am trying to run in VMware using CentOS 5

/pwnat: invalid option -- p
usage: ./pwnat <-s | -c> <args>
  -c    client mode (default)
        <args>: [local ip] <local port> <proxy host> [proxy port (def:2222)] <remote host> <remote port>
  -s    server mode
        <args>: [local ip] [proxy port (def:2222)] [[allowed host]:[allowed port] ...]
  -6    use IPv6
  -v    show debug output (up to 2)
  -h    show this help and exit
./pwnat -c 3.3.3.3 -p 4444 --proxyhost IP 3.3.3.4 -proxyport 2222 --remotehost IP 8.8.8.8 --remoteport 4444
resulting in this reply 
invalid option -- p
share|improve this question

migrated from stackoverflow.com Mar 27 '11 at 21:54

This question came from our site for professional and enthusiast programmers.

You're specifying the arguments incorrectly. If you look at the pwnat home page (or indeed actually read the help text that's displayed) you'll see that there are no -p, --proxyhost, etc. args. (These are simply supplied after the single -c option's IP address.)

There are some examples on the pwnat home page I've linked to above that should help if you're still stuck.

share|improve this answer

Where did you get --proxyhost from??

The documentation gives an example:

./pwnat -c 8000 <pwnat.server.com> google.com 80

So try this:

./pwnat -c 4444 3.3.3.4 2222 8.8.8.8 4444
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.