Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am using Debian Testing and Gnome Flashback (but it behaves the same in standard Gnome Shell).

It gives me plain white background, and I can't set my own. Also, the settings dialog for background looks funny:

enter image description here

Any ideas?

Edit: I have noticed I got background image back when I turned off "Nautilus controlling desktop". Of course, I no longer see desktop icons this way.

Update: I have installed Ubuntu (with Unity), keeping my /home partition. The same problem appears in Unity! I can't set desktop background.

share|improve this question
    
What does gsettings get org.gnome.desktop.background picture-uri print? –  Joseph R. Nov 19 '13 at 9:05
    
'file:///usr/share/images/desktop-base/joy-inksplat-wallpaper_1920x1080.svg', which seems ok. Look at my edit, the problem exists only when I want to have icons on the desktop. BTW, should this dialog really look like this? –  Mladen Jablanović Nov 19 '13 at 11:03
    
The output seems indeed normal. The dialog, however, should not look like the image you posted. You said you get the same behavior in Gnome Shell, but does Gnome Shell actually work correctly: e.g. does moving your mouse to the upper left corner bring up the "Activities" window? –  Joseph R. Nov 19 '13 at 11:29
    
Yep, Gnome Shell works OK (if one's into that kind of stuff of course), and it shows the background image, unless I check "Have file manager handle the desktop" in the tweak tool. –  Mladen Jablanović Nov 19 '13 at 13:05
    
Related: None of the methods in this U&L Q&A work? How to refresh the desktop background in various desktop environments? –  slm Mar 9 at 18:08

4 Answers 4

Managed to solve the problem, at least in Unity, but I guess it would work in Gnome 3 as well:

This setting was false:

$ gsettings get org.gnome.desktop.background show-desktop-icons
false

So I changed it:

$ gsettings set org.gnome.desktop.background show-desktop-icons true

And got my desktop background and icons instantly.

share|improve this answer
    
Perfect. This worked for me as well. Thanks! –  Bklyn Oct 8 at 14:59

I had same problem, you can fix it by setting in Tweek_tool/Desktop file manager handler and icons visible - OFF

share|improve this answer
2  
Can you add a bit more details to this A? –  slm Mar 6 at 14:27
    
Sure. after some updates (I have Debian Testing and Gnome 3 too), I notice that I don't have my background image on desktop (background became white, changing image didn't help), and I tried to find how to fix it but the only way I found it's to remove icons from desktop, using tweak tool –  Alex Mar 9 at 17:32

Some people are missing the point, IF you want your icons on the Desktop AND wallpaper. Gnome has decided you can not. It used to work, but now it doesn't.

Of course if you DON'T want icons, it doesn't matter, but if you DO want icons on your desktop AND wallpaper background it has been decided you can no longer have that.

This is one of the reasons Gnome has gone off track, lack of customization of things you might want, and imposition of things you don't want.

share|improve this answer
3  
Do you have any reference about the fact this is a feature and not a bug? –  sloriot Mar 25 at 8:28
    
Actually, it seems it is a bug in nautilus (bug report) –  sloriot Jun 18 at 22:11

Nautilus stops rendering the background because gnome-shell starts drawing it. Debian and Ubuntu are applying a patch to reverse the changes in Nautilus.

See Debian bug report titled: nautilus: White background when nautilus is managing the desktop.

excerpt

With my machine up to date, nautilus is drawing a white background when it's managing the desktop instead of the expected wallpaper. I can reproduce this with a new empty profile.

I'm not sure this is directly related to nautilus, this might be caused by other libraries in the stack.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.