Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Can't install any packages on Debian 7.2 through the apt-get

root@sandbox:~# apt-get install curl
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 curl : Depends: libcurl3 (= 7.26.0-1+wheezy3) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


root@sandbox:~# apt-cache policy curl
curl:
  Installed: (none)
  Candidate: 7.26.0-1+wheezy3
  Version table:
     7.26.0-1+wheezy3 0
        500 http://security.debian.org/ wheezy/updates/main amd64 Packages
        500 http://mirror.yandex.ru/debian-security/ wheezy/updates/main amd64 Packages
        500 http://mirror.mephi.ru/debian-security/ wheezy/updates/main amd64 Packages


root@sandbox:~# cat /etc/apt/sources.list
deb http://security.debian.org/ wheezy/updates main contrib
deb-src http://security.debian.org/ wheezy/updates main contrib

#deb http://mirror.yandex.ru/debian-security/ wheezy/updates main contrib non-free
#deb-src http://mirror.yandex.ru/debian-security/ wheezy/updates main contrib non-free
#deb http://mirror.mephi.ru/debian-security/ wheezy/updates main contrib non-free
#deb-src http://mirror.mephi.ru/debian-security/ wheezy/updates main contrib non-free

apt-get -f install also does not work

share|improve this question
    
Perhaps your yandex.ru mirror is not complete?It will be slower but what happens if you use deb packages.debian.org wheezy/updates main contrib non-free instead? –  terdon Nov 15 '13 at 17:12
    
@terdon Turn off mirrors. deb http://packages.debian.org wheezy/updates main contrib non-free raise error: E: GPG error: http://packages.debian.org wheezy/updates Release: The following signatures were invalid: NODATA 1 NODATA 2 on apt-get update –  ole Nov 15 '13 at 17:18
    
Sorry, my bad, that should have been http://http.debian.net/debian but never mind, I think Martin is right. –  terdon Nov 15 '13 at 17:20

1 Answer 1

up vote 3 down vote accepted

Your sources.list is broken - it is missing the "stable" part of the repository which contains the bulk of all Debian packages. You've only added the "wheezy/updates" part which only contains updates for some packages from "stable".

It should instead probably look something like this (generated with http://debgen.simplylinux.ch/ , assuming you are located in Russia):

deb http://ftp.ru.debian.org/debian stable main contrib non-free
deb http://ftp.debian.org/debian/ wheezy-updates main contrib non-free
deb http://security.debian.org/ wheezy/updates main contrib non-free
share|improve this answer
    
Yep, you right. Thx. –  ole Nov 15 '13 at 17:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.