Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have installed Request tracker in my RHEL 5.6 system. The RT installation succeeded and I have also installed apache web server, mysql, phpmyadmin that is required for running the request tracker tool. However, in the final step, it is mentioned as, for opening RT we have to enter http://serveripaddress/rt.

I have apache web server installed in my system. So, I am just typing http://localhost/rt in my system. However, it gives me a 404 page not found error.

I believe it has something to do with the rt_siteconfig.pm file. The file's contents are as below.

# Any configuration directives you include  here will override
# RT's default configuration file, RT_Config.pm
#
# To include a directive here, just copy the equivalent statement
# from RT_Config.pm and change the value. We've included a single
# sample value below.
#
# This file is actually a perl module, so you can include valid
# perl code, as well.
#
# The converse is also true, if this file isn't valid perl, you're
# going to run into trouble. To check your SiteConfig file, use
# this comamnd:
#
#   perl -c /path/to/your/etc/RT_SiteConfig.pm

Set($rtname , 'test');

Set($Organization , "www.uta.edu");
Set($Timezone , 'US/Central');


Set($WebPath , "/rt");
Set($WebPort , 80);# + ($< * 7274) % 32766 + ($< && 1024));

Set($DatabaseUser , 'rtuser');
Set($DatabasePassword , 'rtuser');
Set($DatabaseName , 'rtdb');


1;

I believe the webPath parameter has to be modified. But am not sure what to edit in it. Can someone please guide me in the right direction?

Update:

There is a file as rt.conf which sets the RT script path as below in this file.

AddDefaultCharset UTF-8
Alias /rt/NoAuth/images /usr/local/rt/share/html/NoAuth/images/
ScriptAlias /rt /usr/local/rt/sbin/rt-server.fcgi/

DocumentRoot /usr/local/rt/share/html
<location /rt>
       Order allow,deny
       Allow from all
       Options +ExecCGI
       AddHandler fcgid-script fcgi
</Location>

When I just run localhost I am getting the test page successfully and it specifies the welcome.conf file needs to be disabled, in case I do not want the test page. The welcome.conf file is present in the same path as the above rt.conf file. The path is /etc/httpd/conf.d/

Update 2:

The error_log file inside /var/log/httpd has the below line.

[error] [client 127.0.0.1] File does not exist: /usr/local/rt/sbin/rt-server.fcgi/

However, I do have the file rt-server.fcgi inside the above path.

Update 3:

The rt.conf file which is a configuration file for starting the RT is as below.

AddDefaultCharset UTF-8
#Alias /rt/NoAuth/images /usr/local/rt/share/html/NoAuth/images/
ScriptAlias /rt /usr/local/rt/sbin/rt-server.fcgi/

DocumentRoot "/usr/local/rt/share/html"
<Location /rt>
       Order allow,deny
       Allow from all
       Options +ExecCGI
       AddHandler fcgid-script fcgi
</Location>
share|improve this question
add comment

1 Answer 1

Take a look at the Apache access_log and error_log log files under /var/log/httpd/. This will help to show you more information about the error you're encountering.

In your main Apache config file, /etc/httpd/conf/httpd.conf, confirm that Apache is listening on port 80, which it should be, since you're getting a 404 from the server.

You might need to set this variable in Apache:

#ServerName www.example.com:80

Lastly I'd change the string in the rt_siteconfig.pm file to localhost:

Set($Organization , "localhost");

Just to start. Once it looks to be working then adjust it and the Apache value so that they're the same.

share|improve this answer
    
I have added the error log contents as update. Also, I modified the ServerName as ServerName localhost:80 and also modified the rt_siteconfig.pm as you had suggested. I still get "404 page not found" error. –  Ramesh Nov 14 '13 at 20:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.