Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am trying to install Request Tracker tool in my RHEL 5.6 machine.I am following the instructions as mentioned in this link. However, I am facing couple of issues.

The first issue is in the below step. I have some dependency issues for php files.

# yum install  rpm* nmap expect vsftpd net-snmp* ntp* subversion subversion-devel 
mysql mysql-server mysql-devel screen perl-Crypt- PasswdMD5 graphviz php-xml 
php-cli php-mhash php-ldap php-devel php-pdo php-imap php-readline 
php-ncurses php-soap php-snmp php-common php-mcrypt php-odbc php-mbstring 
php-gd php-bcmath php php-xmlrpc php-pear php-mysql php-dba mod_perl-devel 
mod_auth_mysql mod_perl mod_authz_ldap gd gd-devel gd-progs gcc* 
-- exclude=gcc-java* -- exclude=gcc4-java phpmyadmin mod_fcgid perl-GD 
perl-GnuPG-Interface perl-GraphViz perl-YAM 

So, I tried to do the below command.

yum install php

When I do the above command, I received the below message.

Package matching php-5.1.6-40.el5_9.i386 already installed. Checking for update.
Nothing to do

So, as per the tutorial link, I needed phpmyadmin. So, I used the below command.

It gave me the below output.

Error: Missing Dependency: php-api = 20041225 is needed by package php-mcrypt-5.1.6-5.el5.i386 (epel)
Error: Missing Dependency: php-common = 5.1.6-40.el5_9 is needed by package php-gd-5.1.6-40.el5_9.i386 (rhel-i386-server-5)

If I try to install the missing dependencies, php-common using yum command, I receive the below message.

Package matching php-common-5.1.6-40.el5_9.i386 already installed. Checking for update.

If I try to install the missing dependency, php-api using yum command, I receive the below message.

php53-common-5.3.3-21.el5.i386 from rhel-i386-server-5 has depsolving problems
  --> php53-common conflicts with php-common

How can I install the phpmyadmin so that I can continue with the installation of Request tracker tool?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Take a look at this thread, it appears to be the same issue you're running into. The thread is titled: CentOS 6.0, php-mcrypt. I realize this thread is discussing CentOS 6, and you're using 5.6, but the issue is still the same.

To resolve this you'll need to add the Remi RPM repository and then install the php55 packages from there. This should clear up your issue.

php55-mcrypt

Use the appropriate PHP packages from this repository instead!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.