Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have installed Debian 7 64bit on my brand new laptop Fujitsu Lifebook NH532.

As I understood lately this is UEFI-enabled laptop. At first installation attempt I've not created EFI boot partition, so after the istallation process the system simply didn't boot.

Then I reinstalled and during the partitioning process created an EFI boot partition. After the reinstall system still was not able to boot, saying

PXE-E61: Media test failure, check cable
PXE-MOF: Exiting PXE ROM
Boot Failure

Suddenly I've noticed that the boot menu (triggered by F12) has a new line "debian". When selecting that, Debian loads just fine. But why doesn't load it by default? Why should I have to press F12 and select "debian".

When I played with the bios settings and disabled CSM (Compatibility Support Module in Advanced bios tab) Debian starts loading immediately after power on, BUT the GUI doesn't start ("_" blinking at top). Ctrl-Alt-(F1 - F6) consoles work fine.

What have I done wrong and how can I make it start Debian just after power on?

share|improve this question

1 Answer 1

I think the problem should be solved by changing the boot order, by making sure your disk drives are tried first.

According to ths page, if I understand it correctly, the CSM would change the way your machine executes Option ROMs. My theory is this is what is impacting your network card's PXE Option ROM, so your system doesn't even try to boot over the network anymore and falls back to booting from your disk drive. This might impact your graphic card's Option ROM as well, which usually is needed by the graphic card driver and it might explain your text-only boot after disabling CSM.

You can check if this is the case if your dmesg output is showing some failure when loading your graphic card's driver module due to missing Option ROM functions.

Try to re-enable CSM and change the boot order instead. It might also be named 'Boot device priority' in the BIOS Setup menu.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.