Sign up ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

I have a Debian system working as a wireless router with eth0 and wlan0. Now I added an additional network manually on eth1 with ifconfig:

alix:~# ifconfig eth1 netmask
alix:~# netstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface         UG        0 0          0 eth0   U         0 0          0 eth1   U         0 0          0 eth0   U         0 0          0 wlan0
alix:~# ping
PING ( 56(84) bytes of data.
64 bytes from icmp_req=1 ttl=64 time=0.537 ms
64 bytes from icmp_req=2 ttl=64 time=0.199 ms
64 bytes from icmp_req=3 ttl=64 time=0.188 ms
--- ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2005ms
rtt min/avg/max/mdev = 0.188/0.308/0.537/0.161 ms

Everything works fine as you can see.

Now I would like to make the configuration permanent. Therefor I added the following section to /etc/network/interfaces:

alix:~# sed -n '/iface eth1/,/^$/p' /etc/network/interfaces
iface eth1 inet static

But when I try to start the network I get the following error:

alix:~# ifconfig eth1 down
alix:~# ifup -v eth1
Configuring interface eth1=eth1 (inet)
run-parts --verbose /etc/network/if-pre-up.d
run-parts: executing /etc/network/if-pre-up.d/hostapd
ip addr add broadcast     dev eth1 label eth1
RTNETLINK answers: File exists
Failed to bring up eth1.

When I run the ip command manually I get the same error:

alix:~# ip addr add broadcast     dev eth1 label eth1
RTNETLINK answers: File exists

What is wrong with the command? And how can I tell Debian to do the right thing?

share|improve this question

1 Answer 1

up vote 34 down vote accepted

Sorry but I got it myself. I had to flush the device before bringing it up:

alix:~# ip addr flush dev eth1
share|improve this answer
I still receive a (slightly different) error RTNETLINK answers: No such process Failed to bring up eth1 BUT my Eth1 is correctly assigned now AND is UP/UP. – harperville Sep 10 at 14:11

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.